What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Jotform returns N/A to zapier/podio in all empty fields

    Asked by ihege on July 22, 2015 at 07:28 PM

    I forun out that when I enable "Hide empty fields in Email" the form returns N/A in all the empty fields, and thats a big problem for me becauce i have categories so the form gets an error message in zapier..

    In the other first form I have this didn't happen

    I cleared the cache many times, and tried to enable and disable the "Hide empty fields in Email" many times but it happens all the time.. 

     

    What can it be?

     

    the form with the problem is "Bestillingsskjema pannebånd og luer" can you help me? im loosing my mind here;)

    Page URL:
    http://gulltopp.net/bestillingsskjema.html

    Zapier
  • Profile Image
    JotForm Support

    Answered by EltonCris on July 23, 2015 at 12:21 AM

    I need a little clarification, on your statement the problem occurs when "Hide empty fields in Email" option is enabled? So when you disable this option, the problem was fixed? Or it works with the same option enabled on your other form?

    I check this form (52022961330343) and this option "Hide empty fields in Email" is disabled as of this moment. May I know if the problem is still occurring? Have you tried redoing the integration at zapier? Perhaps this might help. Let us know how this goes.

    May I also suggest to make a clone with your form, then try this form on zapier, see if this makes any difference.

    If none of the above suggestion works, please let us know so we can check this in depth.

    We'll await your updates!

  • Profile Image

    Answered by ihege on July 23, 2015 at 02:44 AM

    Yes that is true, i dont want to show the empty fields in email, but had to disable this function to make the zap work..

    I will try to clone the form:) didn't know that was an option

     

    thanks!!! Will let you know if it works

  • Profile Image
    JotForm Support

    Answered by EltonCris on July 23, 2015 at 06:01 AM

    Thanks. Please do inform us if the issue persists when "Hide empty fields in Email" is enabled so we can pass this to our developers for further investigation. If you can provide screenshots of the result from your podio account, we'd appreciate it.

  • Profile Image

    Answered by cheekyface on September 09, 2015 at 03:37 AM

    Any resolution to this?  I've only just recently encountered this for a form I've been using for ages.  I get "N/A"  via zapier to Zoho CRM.
    I'm sure it's zapier but they take so long to reply so I thought ihege may have a solution?

     

    Cheers,

    Danny

  • Profile Image

    Answered by ihege on September 09, 2015 at 08:54 AM

    I didn't solve the problem, I can't hide the empty fields... 

  • Profile Image
    JotForm Support

    Answered by EltonCris on September 09, 2015 at 12:43 PM

    @ihege

    Thanks for your update. Did you get a chance to create a new zapier integration using the same form or at least update and remap the fields on Zapier? Make sure to check if there are no static elements are map on Zapier like submit button, pagebreak or text. This will return "N/A" value on Zapier. Kindly review. Thank you!

  • Profile Image

    Answered by ihege on September 09, 2015 at 01:04 PM

    Yes i Even made a brand new form from the bottom... I gave up and worked around it...better to show empty fields in the email than to have to make a rule for n/a... I'm thinking of using globiflow instead, maybe it will work there

  • Profile Image
    JotForm Support

    (Private)

    Answered by EltonCris on September 09, 2015 at 02:42 PM

    Thanks for your reply.

    We will check and investigate this further and submit it to our developers if necessary. However as for now, I have no clue as to why it is happening since during my test, blank data are submitted as blank and not "N/A".

    Here's an example raw data that will be sent to Zapier if you are going to leave fields blank and with values.

    Have you tried contacting Zapier so far about this problem? Perhaps they can at least check and provide you any clues or solution if possible? I'm sure they will be able to help, thus if you want continue with Zapier integration or if you are fine with "hide empty fields on emails" option being disabled as somehow the working solution.

    Thanks for your cooperation by the way, we greatly appreciate it.

  • Profile Image

    Answered by ihege on September 09, 2015 at 02:50 PM

    But the n/a only appears when hide blank fields are turned on, I turned that off now...

  • Profile Image

    Answered by Ben on September 09, 2015 at 05:50 PM

    I just made a clone of your form and submitted it - with the same setting turned on (enabled) and I see the same as my colleague:

    Please do note that the N/A might be returned by zapier since the rows are not filled out, they might be saving the data as N/A on their end - as in "Not Applicable to get the specified data"

    We do work with them, so if the issue is not on their side, they know how to contact us with the data that they send and the data that we sent, but from what I can see we are sending "" for the fields (with and without the setting enabled).