What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Radio buttons not saving in Firefox, Chrome, IE or Safari

    Asked by evandillon on December 08, 2011 at 03:24 PM

    Doesn't appear that a user's radio button selections are saving when a user clicks save and continue then reloads the form in any of these browsers

     

  • Profile Image
    JotForm Support

    Answered by Mike_T on December 08, 2011 at 06:26 PM

    As far as I understand, you are reporting the same issue about sessions. I can not reproduce it from my side. Please provide us with the link to your form, then we will re-check it.

    We are looking forward to hearing from you.

     

  • Profile Image

    Answered by evandillon on December 08, 2011 at 06:41 PM

    idarktech has the link to the form, please check with him.

  • Profile Image
    JotForm Support

    Answered by Mike_T on December 08, 2011 at 07:42 PM

    I am sorry to say, but the problem is still not clear for me.

    I was able to use Back & Next buttons without data loss. I have also tried with the  https://my.your_domain.org/forms/form/13191144275?session=session_name and it was okay.

    Could you please provide us with the exact steps in order to reproduce the problem?

  • Profile Image

    Answered by evandillon on December 08, 2011 at 11:02 PM

    Exact steps:

    - go to the page with a session variable set in the query string.

    - enter in data, selecting radio buttons along the way

    - click next

    - now close the browser

    - open a browser, go to the same page with the same session variable set

    - on first page, none of the radio buttons have the user's  selection when the page loads (none of the radio buttons are selected) All other data is there, just not the radio buttons.

    I've rebooted, tried different session variables, you name it. I've tried different computers, different browsers, browswers running inside of citrix, browswers running inside of VMWare Fusion. I've tried from my work network and my home network and the same things happens. I've other people try, and the same things happens to them. Perhaps JotForm support should test another way? I've been able to reproduce the issue in every way I've tried, without exception.

    I am using the standalone version of JotForm. Aytekin, co founder of JotForm has my contact information which includes my direct line. I will gladly share my screen, or whatever else it takes! Just give me a call!

    I've even tried a new session variable, clicked next, closed the browser and then pasted the query string into another browswer (as in safari first, then chrome) Same problem. Radio buttons aren't selected. 

    Don't know what else to tell you. Firends, these issues are reported by my end users and I can reproduce them on my installation. I cannot reproduce the error using SaaS version of Jotform, but easy to reproduce on my standalone version.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on December 08, 2011 at 11:36 PM

    @evandillon

    Unfortunately, Jotform.com's support team (that includes me), does not have enough resources to provide support for your type of purchased product.

    As your problem occurs on the licensed installation on your server, it is best to coordinate with Aytekin or any of our developers via email.  Anyway, I would like to confirm that the email message you sent about this issue has been received directly by our developers.

    You will be contacted as soon as they have the opportunity to take a look at your case. We are sorry for any inconvenience caused by these problems.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on December 09, 2011 at 12:37 AM

    Update:

    I was able to recreate your issue using session variables on the form's direct URL (still hosted on your server). With that in mind, I sent an email to our developers to let them know what exactly the problem is.

    Kindly correspond with them via the email address [contact@interlogy.com]. Thank you.

  • Profile Image

    Answered by emrew86 on December 21, 2011 at 05:21 AM

    Hi evandillon, when I look at your full source code, I see that you use old sources such as https://d3mc0rm5ezl95j.cloudfront.net/jotform.css?3.1.110.

    You should take full source code again or use iframe. I advise you to use iframe because sometimes we must change js source urls.

  • Profile Image

    Answered by evandillon on May 09, 2012 at 06:45 PM

    Best I can tell, the release value of "3.1.110" is hardcoded in the php source. Which release should I be using?

     

    note: I am using jotform standalone

  • Profile Image
    JotForm Support

    Answered by liyam on May 09, 2012 at 10:43 PM

    Hello,

    Let me forward this matter to the development team.  They will be responding to this thread as soon as they can.

    Thanks.

  • Profile Image

    Answered by emrew86 on May 13, 2012 at 02:01 PM

    Hi evandillon, this bug has aldready been fixed. You can test it with this form ( http://form.jotformeu.com/form/21335650822347?session=NeilVicente )

    As I said before, you should take source code again.