merchant login ID or password is invalid with Authorize.net

  • Profile Image
    JoeTSM
    Asked on July 24, 2015 at 05:49 AM

    Hi,

    Please help! We have created a form and each time we use the form showing error although we entered all required information.

    Error during transaction
    The merchant login ID or password is invalid or the account is inactive. 

    Please go back and fix this

     

    Thanks,

    Emily

  • Profile Image
    Kiran
    Answered on July 24, 2015 at 10:06 AM

    Hello Emily,

    Looking at the error message it seems that there is an issue with the Authorize.Net account. Could you re-check if the account is active and using correct username and password. As I test with my sandbox account, the integration seems to be working great at my end. 

    Let us know if you need any further assistance. We will be happy to help.

  • Profile Image
    JoeTSM
    Answered on July 25, 2015 at 10:35 AM

    Hi Kiran,

    Thank you for your reply, but I actually don't know how to change Authorize.Net 

     

    All I did is creating the fields of the form and checked to be secured. 

     

    Could you please let me know how to make this change?

     

    Thanks again

  • Profile Image
    Chriistian
    Answered on July 25, 2015 at 12:31 PM

    Hi JoeTSM,

     

    In order for this to work, you need to make sure that your API Login ID and Transaction Keys are properly set. Looking at your form, they are currently blank. If you are in the testing stage, you also have to make sure that Sandbox Test Mode is enabled.

     

    You might want to look at this article to know how to get your Authorize.net API Login ID and Transaction Keys - https://support.authorize.net/authkb/index?page=content&id=A405.

     

    Do let us know if you need further assistance.

  • Profile Image
    JoeTSM
    Answered on July 27, 2015 at 01:40 PM

    Hi Chriistian,

     

    Thanks for your reply! This explains a lot.

     

    I will fix this.