What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Submissions page not showing properly

    Asked by mlouridas on July 27, 2015 at 09:14 AM

    The JotForm homepage is working just fine, and as far as we can tell, the form on our website is still operating correctly along with the submission emails we're receiving. However when we click the link to drop down to view submissions, we're greeted with a broken up, basic text view. We can see a glimpse of our normal submission view, but it disappears as we scroll and is replaced with a grey background. How/when can this be fixed?

    Screenshot
    view submission Submissions submissions page
  • Profile Image
    JotForm Support

    Answered by Jan on July 27, 2015 at 10:46 AM

    The submissions page is working properly on my end. For now, we don't have any other reports that are related to your issue.

    Please try the following steps:
    1. Log out from JotForm.
    2. Clear your browser cache.
    3. Close and reopen the browser.
    4. Log back in to JotForm and please verify if it is working.

    If the issue persist, please try these other troubleshooting steps so that you can isolate the problem.

    1. Please try to check if it will work on another browser.
    2. Disable browser add-ons and extensions.
    3. Disable your AV and then check if the page is showing properly.
    4. Try it on another device.
    5. Turn off and turn on your wireless router. (Power cycle)

    I cleared your form cache so that your forms will be refreshed from our servers. Hope this works. Let us know if the issue is still the same. Thank you.