Upload file fail on desktop but fine on smartphone

  • Profile Image
    infoashermeow
    Asked on August 02, 2015 at 10:09 AM
    Hello,

    I created a form

    I tested on my iPhone and it worked very well. However, when I tested it on my desktop, it returned this error message: Incomplete Values
    There are incomplete fields in your submission: Upload File is required Please go back and fix the problem(s)
     
     
    I actually uploaded files and also I cleared cache too but it still doesn't work on desktop.
     
    Can you help me with it? Thank you!
     
  • Profile Image
    infoashermeow
    Answered on August 02, 2015 at 10:54 AM

    I noticed the terms and conditions widget seems to be the problem. I don't know why but if I delete the widget I will be able to submit.

  • Profile Image
    Mike_G
    Answered on August 02, 2015 at 12:49 PM

    The error message you received shows that the Upload File field is set to be required and needs to be filled before you can submit your form. I have cloned your form and I was able to submit the form and be redirected to the PayPayl's page. (using Google Chrome) Even with the Terms and Condition widget, I still was able to submit the cloned form.

    By the way, are you still having the same issue? 

    If yes,

    I just would like to ask: 

    What browser were you using when testing your form?

    Is your from embedded on a website when you're trying to submit it?

    Kindly, give us more details of your issue so we may further help you. 

    We will wait for your response. Thank you. 

  • Profile Image
    infoashermeow
    Answered on August 02, 2015 at 05:58 PM

    Thank you for your help. I still have the problem. I did not embed the form in any website when testing.

    I tested the form in Chrome, Firefox and IE with Terms and Conditions widget. Most of the time, it didn't work, occasionally it worked and sometimes, it worked even without me ticking the box before Terms and Conditions even I made it a required item.

    At this point, I just deleted the Terms and Conditions. I tested the form without the widget and everything worked great.

    Anyway, this is my first time using JotForm actually. I am really amazed at how easy everything is and how well the outcome is and also how great the customer support it.

    Thank you very much.

  • Profile Image
    EltonCris
    Answered on August 02, 2015 at 08:30 PM

    @infoashermeow 

    Thanks for providing more information and glad it's somehow working on your end by deleting the widget.

    I've tried reproducing the problem using a clone version of your form and the form I created from scratch. So far on my test, everything seems working just fine. I can't bypass the required validations, specially the terms widget. The upload goes through as well when the form was submitted.

    Here are my screenshots:

    Required validation works

    Form submits after completing all the fields

    The files are available on the email and on the submissions page

    http://www.jotformpro.com/uploads/EltonCris/52137817431958/314369829120702336/edit_buttons_are_showing.gif

    http://www.jotformpro.com/uploads/EltonCris/52137817431958/314369829120702336/edit_buttons_are_showing65.gif

    By the way, instead of using terms widget, you can also use a standard checkbox tool as your terms.

    We will also continue to monitor the forum if we find similar reports and escalate it to our developers if necessary.

    Regards!