Not Receiving Submissions

  • Profile Image
    newmethodanceministries
    Asked on August 02, 2015 at 10:30 PM

    I have had a couple of people trying to submit the order forms that I have through jot form. 

    http://form.jotform.us/form/52038986570161

    http://form.jotform.us/form/52040683673152

    http://form.jotform.us/form/51646331512145

    http://form.jotform.us/form/51995569527171

     

    I have not received notification, nor does on the main page that I have any submissions. How can I resolve this problem?

     

  • Profile Image
    newmethodanceministries
    Answered on August 02, 2015 at 10:32 PM

    http://www.youremajesty.com/#!home/cjg9

    when you hover over order forms, each form is on it's own page.

  • Profile Image
    newmethodanceministries
    Answered on August 02, 2015 at 10:36 PM

    Also They said they received the thank you for your submission screen, but I have not received the actual form itself

     

  • Profile Image
    newmethodanceministries
    Answered on August 03, 2015 at 10:36 AM

    OK someone else tried to submit an order form the basic and customizable order forms. I did not receive a submission on my home screen.

    http://form.jotform.us/form/51646331512145

    http://form.jotform.us/form/51995569527171

    They did receive a thank you for your submission. But I never received the form. The submission still says 0

  • Profile Image
    Charlie
    Answered on August 03, 2015 at 11:55 AM

    Apologies for the inconvenience.

    I checked those forms and they both don't have email notification on them. Please set one for each form.

     

    I also made a test submission on the form "Basic Order Form", you'll see it in the submissions page. I just opened the direct link, filled it out and clicked the submit button. Have you tried testing your form?

    I also noticed that you are embedding it in your Wix.com website, have you tried embedding the form using an iFrame embed code instead? Your website might be conflicting with your form's back end code. Try re-embedding and directly testing your forms in that website by filling them out and clicking the submit button.

    Would it be possible to know what browser your users are using when they filled out the form? It is quite unlikely that no submission will be sent to your account if they have submitted it properly.

  • Profile Image
    newmethodanceministries
    Answered on August 03, 2015 at 10:54 PM

    No. I am not sure what web browser they are using. I have used jotform (embedded) before on wix but it was with registration forms for a website, and I never had an issue with not receiving any of the submissions. Me not receiving the email notifications is really not an important issue. It's when I go to my forms, and it says 0 submissions when I know for a fact there should be 6. It goes through on their end, but I don't receive it.

  • Profile Image
    Charlie
    Answered on August 04, 2015 at 02:22 AM

    Apologies for the inconvenience. But I can't still find in our records that there are submissions on those forms you mentioned that went through in our end.

    Wix.com might have updated something in their end that may have conflicted with your forms, please do try replacing all your form embed codes using our iFrame embed. It is also possible that there's a plugin in Wix that causes the problem. Here's a guide on how to embed the form in your Wix website: https://www.jotform.com/help/70-Adding-a-Form-to-Wix-Site 

    You can also check your form's analytics if there are submissions received from that specific forms.

    I see that "Basic Order Form" has 2 submissions, one came from my test submission.

    I also check "Build Your Own Flag".

     

    I also check your page here: http://www.youremajesty.com/#!build-your-own-flag/ccmt. And I tried filling it out, but it doesn't submit, here's a sample test I made.

    You'll see in my screen cast that it doesn't submit. It seems like the embed code you used on that page is not working. Please do try re-embedding using the iFrame embed code. A code conflict seems to be happening causing problems on the submission, it's either you can't submit or the submission was not sending.

    Please do check the pages that your forms are embedding and see if you can proceed on submitting.