Survey Answers showing up blank on spreadsheet and email report.

  • Profile Image
    dansimrell
    Asked on August 17, 2015 at 03:50 PM

    I am creating a survey to send to customers for mostly yes or no questions and a couple multiple choice. I am copying and pasting the source code to embed the survey into an email. Through my tests I was able to go through and complete the survey via submission and return a "thank you!" page. However, on my email report back and the Google Spreadsheet integration I have setup, I am only getting the submission date and time, with all question showing blank responses next to them in the answer column. 

    Has anyone else experienced something like this? I have added calculated values to the questions, but that did not seem to work either.

     

  • Profile Image
    Welvin
    Answered on August 17, 2015 at 07:06 PM

    I was able to submit the form and could see the data in the form submissions page. This is the form in question http://www.jotform.us/form/52286260072148, right?

    The issue here is related to the way how you publish the form. Note that we do not recommend embedding the form into an email message. Some programs will allow you to do that, but the majority aren't. There are scripts in the form that is required for the form to work properly and some email programs will just reject this which will cause you a problem in the form/submissions.

    In this case, please publish the form using its direct URL instead. Or, embed it to your website. Here's how you can do that: http://www.jotform.com/help/67-Which-Form-Embed-Code-Should-I-Use. But if the issue persists after doing this, please let us know so we can investigate further. We can submit the thread to our developers if there's a bug in the form.

    Thanks