What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Authorize.net: On Sandbox Mode when using a coupon code after submit a Blank screen is displayed.

    Asked by milbra on August 24, 2015 at 10:31 PM

    I'm trying to learn how to use the Authorize.net sandbox using JotForm. I created the form, "V2 Test", by adding a couple of sample books and submitted using the dummy credit card and personal info supplied by Authorize.

    On Submit, I get a blank screen. If I press <ENTER>, I get a the following message...

    "Incomplete Values
    There are incomplete fields in your submission.
    Please go back and fix the problem(s)."

    Nothing is recorded in JotForm Submission, nor Authorize. Looking forward to hearing from you.

     

    Page URL:
    http://form.jotformpro.com/form/52357684130960

    Authorize.net form after JotForm problem message credit
  • Profile Image
    JotForm Support

    Answered by Chriistian on August 25, 2015 at 02:37 AM

    Hi,

     

    I've cloned your form and did a test submit but I didn't replicate the issue. The cloned form is http://support.jotform.com/form/52360981778972. Did you embed the form already when you test it? Can you provide us a URL of website(if you already have embedded the form)?

     

    Can you try clearing up your form cache and see if it works?

     

    We will wait for your response.

     

    Regards.

      

  • Profile Image

    Answered by milbra on August 25, 2015 at 02:34 PM

    I'm at a different computer right now.  My form still would not work even after clearing the cache, but the cloned form works. The only difference I see is that mine has a coupon field and displays the subtotal and total.

    I haven't embedded in a webpage yet, just testing using the embed address.

  • Profile Image
    JotForm Support

    Answered by BJoanna on August 25, 2015 at 04:43 PM

    I have tested your form and I was not able to reproduce mentioned issue with blank screen. I got this message after I submitted the form, because credit card number I entered inside of the form is not valid.

    If you are still getting same error please try to reintegrate payment field. 

    Let us know if you need further assistance. 

     

     

  • Profile Image

    Answered by milbra on August 25, 2015 at 07:22 PM

    I've added a hidden text field that contains dummy credit card information for you.

    I cloned my original form then removed the coupon - it works. But, the reason I'm trying to use JotForm is because a need a coupon which is fffective for a stated period of time.  Hope you can you help.

  • Profile Image
    JotForm Support

    Answered by Chriistian on August 25, 2015 at 11:02 PM

    Hi,

    I did some test submission in your form and I was able to replicate the issue. First, I did a test submission using the info you have provided in the hidden field in your form without adding a coupon detail and it was submitted successfully.

    Then on my second test, I did a test submission again using the same info but I have inputted a value on the coupon field. And a blank screen was displayed.

     

    Let me escalate this issue to our development team for them to further check the issue. We will inform you on this thread any updates on this issue.


    Regards. 

  • Profile Image

    Answered by milbra on August 29, 2015 at 05:09 PM

    Any word form the development team yet?  I was trying to use JotForm for the coupon feature.

  • Profile Image

    Answered by Shadae on August 29, 2015 at 11:56 PM

    Hi milbra,

    I do apologize, there has not yet been an update on this issue. It has however been assigned to one of our developers and has been marked as important.

    Once there is an update on the issue, it will be posted on this thread.

    Thank you for your patience and understanding while we look into having this issue resolved.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on September 11, 2015 at 07:38 AM

    @milbra

    May we ask if you are still having this problem? Our recent tests conclude that the bug is no longer present, but if it's not the case for you please let us know immediately.

    Thanks!

  • Profile Image

    Answered by milbra on September 11, 2015 at 07:43 AM

    Yes.

  • Profile Image
    JotForm Support

    Answered by david on September 11, 2015 at 01:30 PM

    I tested your a clone of your form and the coupon code feature appears to be working properly.  Here is my test form with the coupon code enabled:

    http://form.jotformpro.com/form/52535640763962

    The coupon is "test1".  In sandbox mode I am able to submit the form with or without the coupon code applied.  Can you confirm that is working now for you as well?

    You can clone my copy if you would like:

    https://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL

  • Profile Image

    Answered by milbra on September 11, 2015 at 08:59 PM

    Thanks! 

    I went back to my original form, which still doesn't work.  I don't see what is wrong with it, but it doesn't matter because the cloned form did work.

     

    I added the coupon feature to the actual form I want to use and it works.

    Thanks again.

     

  • Profile Image

    Answered by Shadae on September 11, 2015 at 11:20 PM

    Hi milbra,

    Thank you for providing us with that update. We are happy to hear that the feature is working an desired.

    Please feel free to contact us if you need further assistance.

    Thank you