logics,hide field and drop down questions not working.

  • Profile Image
    nevillemwalimo
    Asked on August 30, 2015 at 04:43 PM

    hi i have created a survey called rental but its drop down choices and not shown in the preview and survey link and the logics and hide fields that i have applied are not working.

  • Profile Image
    Welvin
    Answered on August 31, 2015 at 07:02 AM

    When setting up a conditional logic, you don't need to duplicate it for the "HIDE" field rule. The "SHOW" field rule is enough. 

    For example, your conditional logic 1 and 2:

    You don't need the 2 because the conditional logic for "YES" will automatically hide the field and show it after you select the option in the field.

    Thanks

  • Profile Image
    nevillemwalimo
    Answered on August 31, 2015 at 07:45 AM
    how about the data i entered in the drop down menu,its not showing when am
    previewing the form.
    *Neville Mwalimo,*
    *P.O BOX 69336 - 00400.*
    *Nairobi.*
    *+254722853977.*
    ...
  • Profile Image
    Welvin
    Answered on August 31, 2015 at 09:37 AM

    What dropdown field? Can you name the label, please? But I think it's not showing up in the preview because of the conditional logic which currently hide the field. Let me know the field name and I'll check it.

    Thanks

  • Profile Image
    nevillemwalimo
    Answered on August 31, 2015 at 11:45 AM
    its fro the drop down question for states.
    *Neville Mwalimo,*
    *P.O BOX 69336 - 00400.*
    *Nairobi.*
    *+254722853977.*
    ...
  • Profile Image
    Welvin
    Answered on August 31, 2015 at 01:47 PM

    You have a few "States" field in the form and some of them are properly configured and some aren't which just shows the default options. You have to edit the fields and add your states, just like the other state fields.

    Thanks