What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Draw On Image widget is not working on secure forms

    Asked by jk8conmed on September 05, 2015 at 11:08 PM

    Several users have reported that they couldn't submit the form. I then also tried and the button just hangs on "please waiting..."

    Page URL:
    https://secure.jotform.us/form/42676318142152

    then and reported
  • Profile Image
    JotForm Support

    (Private)

    Answered by BJoanna on September 06, 2015 at 05:08 AM

    I was able to submit your form but I noticed that image inside of Draw Inside of Image widget is not loaded. I tried to submit form that is not secure (HTTP) and when I draw on image I was able to reproduce mentioned issue.

    I will escalate this issue to our developers and we will inform you via this thread once the issue is resolved. 

    For now as workaround I would suggest you to use non secure form and to upload image inside of Jotform Form Builder and than to add link of your uploaded image inside of Draw on Image widget. 

    Here is my cloned form: http://form.jotformpro.com/form/52481931633961? 

     

    Feel free to clone it. 

  • Profile Image

    Answered by PunkHealth on October 14, 2015 at 08:57 AM

    Any update on this, please? I've uploaded an image and referenced that as per the instructions, but on iOS devices it still shows the spinning wheel perpetually :-(

  • Profile Image

    Answered by Sammy on October 14, 2015 at 12:09 PM

    I have refreshed your widget integration, kindly test again and let us know of the outcome. Also try testing on chrome browser on your device.

    I will leave a note to our developer regarding the status of the resolution.

  • Profile Image

    Answered by PunkHealth on October 14, 2015 at 12:26 PM

    Thanks Sammy,

    I've tried again on Safari on iOS - no difference

    On Chrome, it works like a charm. Please let the developers know

     

    Thanks for getting back so quickly, too :-)

     

  • Profile Image

    Answered by Sammy on October 14, 2015 at 01:37 PM

    Thank you for the confirmation, I will forward this detail to our developers.

  • Profile Image

    Answered by jk8conmed on October 15, 2015 at 02:31 PM

    Still not working for me

  • Profile Image

    Answered by Carina on October 15, 2015 at 04:38 PM

    Thank you for the update. This ticket was assigned to a developer but has a low priority status so for now I would recommend using the workaround suggested by Bjoanna.

    As soon as we have more details we'll contact you via this thread.

    If you need further assistance please let us know.

  • Profile Image

    Answered by PunkHealth on October 15, 2015 at 05:45 PM
    Thanks for the update - the only problem is that the workaround doesn't work on iOS. You'll see it's completely broken when using the Safari browser. I would have though that would make it a higher priority?
    Regards,
    James
    ----


    James Chard |Practice Manager
    James@BxClinic.co.uk |01603 327999
    Norfolk Biomechanics Clinic:
    79 Thorpe Road, Norwich, NR1 1UA
    http://www.BxClinic.co.uk
    The information contained in this email, including any attached files, is strictly confidential and solely intended for use by the individual(s) and/or entities to whom it is addressed. If you receive this email in error please delete it and notify Reception@BxClinic.co.uk by return. Whilst reasonable effort has been made to ensure this message is free of viruses, opening and using this message is at the risk of the recipient. Please ensure you have adequate security measures in place before opening emails, and in the unlikely event that you detect a virus or other threat, please notify us immediately.
    ---- On Thu, 15 Oct 2015 21:37:52 +0100 JotForm Support Forum<jotform@jotform.com> <noreply@jotform.com> <noreply@jotform.com> wrote ----
    A new response has been received:
    Answered by Carina
    Thank you for the update. This ticket was assigned to a developer but has a low priority status so for now I would recommend using the workaround suggested by Bjoanna.
    As soon as we have more details we'll contact you via this thread.
    If you need further assistance please let us know.
    View this thread on browser » Unsubscribe Thread
    1444941488
    ...
  • Profile Image
    JotForm Support

    Answered by ashwin_d on October 16, 2015 at 01:48 AM

    Hello James,

    This issue is already reported to our back end team. I did check the ticket status and found that one of our developer is already looking into this issue. We will get back to you as soon as we have any update on this.

    Thank you!

  • Profile Image

    Answered by PunkHealth on November 03, 2015 at 10:22 AM

    it's broken again.....and on Chrome.

    Is this linked to the EU Safe Harbour workaround?

    This is mission critical for us, so a high priority response and fix would be appreciated.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on November 03, 2015 at 12:42 PM

    Hello PunkHealth,

    I did check your last edited form and it seems to be working as expected. The "Draw On Image" widget  is working fine with non secure form URL. Please check the screenshot below:

     

    Can you please test your form again and get back to us what is not working?

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by jk8conmed on November 03, 2015 at 04:25 PM

    Generally the problem is not the drawing part, but the submitting part.

     

  • Profile Image
    JotForm Support

    Answered by Chriistian on November 03, 2015 at 09:26 PM

    Hi,

     

    I tried a test submission on your form - http://www.jotformpro.com/form/42813074418958 but I was not able to replicate the issue you are reporting. The form was submitted successfully. 

     

    Also, I tried a test submission on the form you provided in this thread https://secure.jotform.us/form/42676318142152 and still I was not able to replicate the issue. I was able to submit the form successfully.

     

    I tested this in Chrome browser. Can you try it again and see if it is working now?

     

    We will wait for your response.
    Regards.

  • Profile Image

    Answered by PunkHealth on November 04, 2015 at 08:06 AM

    Still definitely not working. Here it is on Chrome: http://take.ms/KrsYq

    Note that the canvas area is smaller than the image - it hasn't been like that before.

     

    Regards,

     

  • Profile Image

    Answered by jk8conmed on November 04, 2015 at 08:56 AM

    I experience the same endless loading that is shown in PunkHealth's video.

  • Profile Image
    JotForm Support

    Answered by BJoanna on November 04, 2015 at 11:30 AM

    @PunkHealth and @jk8conmed 

    Sorry for inconvenience this may caused. 

    I has able to replicate again mentioned issue on your HTTPS forms. One of our developers is assigned to this thread. I will check with him to see if there is any update regarding this issue. 

    Workaround for this issue is to use non secure (HTTP) forms, like I mentioned in my previous post.

    We will update you via this thread once this issue is resolved. 

  • Profile Image
    JotForm Support

    Answered by widgets on November 05, 2015 at 02:23 AM

    Hi PunkHealth. Sorry for the inconvenience. We have already fixed the issue. Loading the widget under secured page should be working properly. But from your form(https://secure.jotform.us/form/42813074418958). It appears that there still an unsecured content being loaded. Make sure that the image you specified on the widget have a https protocol. Otherwise just omit http: (for example: //www.jotform.com/uploads/PunkHealth/form_files/feet.jpg ) as normalize links will work too.

    Try it again and let us know if the problem still persist.

    Regards,
    Widget Team