Google Spreadsheet integration records date values as a weird numbers

  • Profile Image
    kemalo
    Asked on September 08, 2015 at 04:41 AM

    Hi,

     

    When I build a google spreadsheet integration, all of the Date/Time values come as a weird number. And it is not possible to convert this number as date/time value like "dd/mm/yyyy hh:mm"

    Can you please help me?

     

    Regards,

     

  • Profile Image
    EltonCris
    Answered on September 08, 2015 at 05:37 AM

    Thanks for reporting. That is indeed a bug. 

    However, when I performed a test just now, it is showing the date value just fine.

    May I suggest to re-integrate your form to google spreadsheet. This might resolve the problem. Please let me know if not so we can further assist you.

  • Profile Image
    Charlie
    Answered on September 08, 2015 at 09:44 AM

    Unfortunately, I'm also unable to replicate the problem.

    I tried doing the same setup, but it doesn't give an error. However, please try the following steps to resolve the problem.

    1. First, try resetting your Time format in your JotForm's account setting. Choose the correct Timezon and Time Format.

     

    2. After that, remove the integration, clear your form's cache and re-integrate Google Spreadsheet.

    3. Try making a test submission and see if that resolves the problem.

     

    If the above steps doesn't help, you can try setting up the data format in your columns. It looks like your default one is set to have a general number, same with the edit link.

    You could try setting up the date format like this. Choose any of of the number formats listed.

     

     

    Please let us know if any of the steps works. You can also share us the Google Spreadsheet link so we can check it out. But I believe the date and time settings in your account should fix this.

    We'll wait for your response.

  • Profile Image
    kemalo
    Answered on September 08, 2015 at 11:01 AM

    Hi,

    I have done the steps exactly the way you describe. 

    when I make a new google spreadsheet integration, old records come correctly. But after that, new submission come weird  date values.

    So everytime I renew the integration, I get all of the old records correctly. but records still problem. And it all goes on this way. 

  • Profile Image
    oswaldocruzquimica
    Answered on September 08, 2015 at 11:20 AM

    i have the same problem, when i do the reintegration with spreadsheet , the spreadsheet it is right, but when i sent a new form the format stay wrong again.

     

    see the print below:

     

    Look my spreadsheet  link: https://docs.google.com/spreadsheets/d/1BTWStxbIQhHEN53O1wuY8moUDyxUbRMjDARDdNLLKH8/edit?usp=sharing

     

    JotForm link: http://form.jotformpro.com/form/50715386903963

     

    I have the big problem with this error on integration, and i need to help.

     

    Thank you.

     

    regards,

    Dener Leão

  • Profile Image
    Welvin
    Answered on September 08, 2015 at 01:26 PM

    Our apologies for the troubles and inconvenience. But I'm also unable to replicate the problem. Everything works fine, I tried the following to replicate it:

    -change the separator

    -change the time format

    -change the date format

    -change the default date

    -change the default time

     

    Please try doing the following:

    -Replace the current datetime fields and use the default settings which are mentioned above.

    -Re-integrate the form and check if it's still doing the same.

    Lastly, share us here the spreadsheet link as well as the form so we can try it and then will use it as a reference to our developers.

    Thanks

  • Profile Image
    oswaldocruzquimica
    Answered on September 08, 2015 at 02:01 PM

    I already tried to do it. but nothing works.


    Look below the links:

    JotForm: http://form.jotformpro.com/form/50715386903963


    spreadsheet: https://docs.google.com/spreadsheets/d/1BTWStxbIQhHEN53O1wuY8moUDyxUbRMjDARDdNLLKH8/edit?usp=sharing


    Regards,
    Dener leão

  • Profile Image
    Kiran
    Answered on September 08, 2015 at 03:23 PM

    @oswaldocruzquimica,

    I see your post was moved to a separate thread and already addressed by one of our colleagues. We request you to post your responses on the other thread so that we'll be able to address your query properly. 

    Thank you!