Emails are not being sent upon submit

  • Profile Image
    slcfire
    Asked on September 10, 2015 at 01:34 PM

    Several of our users are complaining their forms are not sending them email notifications.  I've tried entering different notification emails to the form indicated below, (both inside and outside our firewall), and nothing is coming through.   Thanks!

  • Profile Image
    criterions
    Answered on September 10, 2015 at 01:39 PM

    I'm seeing this as well - it's working for SOME forms but not for others.
  • Profile Image
    Ben
    Answered on September 10, 2015 at 04:53 PM

    @criterions, I have moved your post to a new thread here: http://www.jotform.com/answers/659420 where we will be assisting you shortly.

    @slcfire I took a look at your form and I see that you are using the Custom sender over verified email setup. Please do note that this is not the best way to send an email, especially if it is sent to the same email or domain.

    Now to resolve this issue, you should either use SMTP setup or send the email from noreply@jotform.com instead.

    You can see guides for both here:

    How to Setup SMTP for a Form

    How to setup email alerts to prevent email bouncing related issues

    Do let us know how it goes.

  • Profile Image
    slcfire
    Answered on September 10, 2015 at 05:52 PM

    Thanks.  I see your notice at the top of the support forum area.  Changing the from address to noreply@jotform.com did the job.  I'll change my critical forms to this address until the issue is resolved.