Custom Button does not Render properly on the Form

  • Profile Image
    dohafamily
    Asked on September 11, 2015 at 04:37 PM
    Now if I can only get the "submit" button to render properly :(
  • Profile Image
    jonathan
    Answered on September 11, 2015 at 05:10 PM

    I checked your jotform http://www.jotformpro.com/form/52515820589966 and I was able to see the issue with the rendering of the Submit button

     

    I cloned the form and made a fix on the CSS on the test form.

    Can you please check the test form http://form.jotformpro.com/form/52536430799969?

    Is this how you wanted the Submit button to be?

     

    We will wait for your response

     

     

  • Profile Image
    dohafamily
    Answered on September 12, 2015 at 10:03 AM

    Thanks Jonathan! Yes, that would be great. 

    Was this something that was caused by the form being imported from AFC and then applying a style to it?

  • Profile Image
    dohafamily
    Answered on September 12, 2015 at 10:15 AM

    Are you also able to lend a hand on these two issues?

    The user input area seems to be nudged up a bit and it's not entirely obvious where the user is supposed to input the information.

     

     

    Also, on this line (only this one) the "my helper's name is:" text is blocked by the text input field. Can you help me nudge the input field down a bit? 

     

    Thanks again for helping this noob!

  • Profile Image
    jonathan
    Answered on September 12, 2015 at 07:16 PM

    Sorry for the delays. I applied the necessary CSS codes to your jotform http://form.jotformpro.com/form/52515820589966? to fix the problem.

     

     

    Please check your form again. Let us know if there is more to be done.

    Regards,

     

  • Profile Image
    dohafamily
    Answered on September 12, 2015 at 10:14 PM

    Thanks Jonathan. I just found another couple of fields where the text field is overlapping the description a bit. If you could help with those that would be great.

     

     

     

     

     

  • Profile Image
    dohafamily
    Answered on September 12, 2015 at 10:27 PM

    Hi again.

    I just discovered that some of my conditional selections are not rendering well on mobile devices. For example, in the "About your Setup" section there's a question about powerpoints. If the user selects any option besides the first one there is a checkbox agreement that pops up. The text is totally different and runs off the page.

     

    You can see how the text "I understand that. . ." is different than other text and doesn't wrap - it goes off the screen entirely.

     

    Do I need to enable the "responsive" option?

     

     

     

     

    Here you can see how it continues off the form completely if I slide the screen to the left.

     

     

     

    Thanks!

  • Profile Image
    jonathan
    Answered on September 13, 2015 at 01:02 PM

    I have fixed the mentioned misaligned textbox as well.

     

    Please check/test again on your form http://www.jotformpro.com/form/52515820589966 if you can find more similar misalignment.

    Thanks.

     

    ---

    We will resolve the next question about responsive form issue on mobile browser here http://www.jotform.com/answers/661188