Contact Form Not Working in Internet Explorer 11

  • Profile Image
    AmeriQualGroup
    Asked on September 21, 2015 at 11:47 AM

    Hey,

     

    I have made a Contact form. It does not show up at all in Internet Explorer 11. The oddest part is that the Contact Us form was built in the same manner as our Job Application form, but the Job Application form shows up just fine in IE. There are no special conditions or widgets that could be causing the problem. This is for a WordPress website so I tried using the WordPress platform code and several other embed options, but none of them work. Do you know what could be going on?

     

    Thanks,

     

    Kristy

  • Profile Image
    jonathan
    Answered on September 21, 2015 at 04:20 PM

    Hi Kristy,

    I checked it on your website using IE11 as well, and I can use the pop-up form just fine.

     

    the pop-up form using the test link

     

    Can you please try first re-embedding your form http://www.jotform.us/form/52596653090158   using instead the Wordpress embed method.

    Follow the user guide on how to: http://www.jotform.com/help/4-Adding-Forms-to-Wordpress-org-version

    Please let us know if still not working.

     

  • Profile Image
    AmeriQualGroup
    Answered on September 22, 2015 at 02:33 PM

    Hey Jonathan,

    I have added several other embed methods of the form to the same page. Please take a look again and let me know what you can see.

    Section 1: The same as before. Just the pop-up method.

    Section 2: The form embedded using the WordPress embed method.

    Section 3: A different form using the same WordPress embed method except we can see this one in IE11 and we can't see the forms in section 1 & 2.

     

    I also tried using the JotForm WordPress plugin, but it must not be compatible with our theme or something. When I click the jot form tool icon in the editor, nothing happens.

     

    I am using Mozilla Firefox to develop this website. Everything is working in Firefox, Chrome, and Safari. If you could please check on your computer and let me know which sections you can see in IE11, that will help me determine whether our IE11 is showing something different than others or not.

     

    http://ameriqualgroup.com/contact-us/

     

    Thanks!

     

     

  • Profile Image
    Ben
    Answered on September 22, 2015 at 03:44 PM

    I have just tried opening the page in IE8 and it seems to be working properly for me as you can see here:

    Please do note however that having 2 js embed codes for your form is very likely to cause issues due to both loading the same resources, calling the same functions, etc, which is likely to cause conflicts.

    Due to this, I would suggest using one with js embed and another with iframe embed code, if you need to have two on the same page - that is if you notice any issues with them.

    Please do take a look at the screen capture above and let us know if you see that something is missing and we would be happy to assist with the same :)