[Quiz App] Quiz form results mark check box inputs incorrect when they are correct.

  • Profile Image
    JohnPeat
    Asked on September 21, 2015 at 06:18 PM

    Hi there,

    I've been using http://quizform.jotform.io/

    One of the questions in my form http://form.jotformpro.com/form/52507142836959 is a checkbox question (question 3)

    The problem is that the system marks the question wrong very time, despite entering the correct answers (see below)

    As you can see question 3 has been marked incorrect.

    I notice that each answer is separated by a ';' in the submitted answer and separated by a ',' in the answers.

    I suspect this is causing the issue. When I change the quiz answers to just 1 check box (i.e. ;/, are removed) instead of the 4 it works.

     

    Any ideas of how to fix this??

     

    Thanks,

    Jordon Retter

  • Profile Image
    Chriistian
    Answered on September 22, 2015 at 03:34 AM

    Hi Jordon,

     

    I did some test submission in your form and I was able to see what you are referring. To further check the issue, I cloned your form, set it up to Quiz app and I was able to replicate the issue. I set the correct answer for item number to b,c,e,f.

    And when I tried to answer the correct answer for number 3 it will still be considered as incorrect.

     

    Let me escalate this issue to our development for them to further check the issue. We will inform you on this thread any updates on the issue.

     

    Do let us know if you need further assistance.
    Regards.