What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form label & answer not displayed in e-mail (gmail) - see screenshots

    Asked by jhjuli20152 on September 24, 2015 at 05:05 PM

    In our form there are four labels & fields defined (pay attention to “Woonplaats”).
    See picture 1

    The generated Jotform code is:
    <script type="text/javascript" src="http://form.jotformpro.com/jsform/52588103819966"></script>

    In Google Chrome we get what we expect on screen.
    See picture 2

    Everything seems ok at this stage, but when we submit..

    The label & answer "Woonplaats" are not displayed in the e-mail.
    See picture 3

    Let's look at the respons in Jotform, it seems ok. Note: "Woonplaats" is present.
    See picture 4

    Question: Why is “Woonplaats” not visible in the e-mail when it is present in Jotform?

    Page URL:
    http://www.bienivitesse.ophetweb.nu/zonnepaneel_mp/4v5.html

    Screenshot
    form label label not displayed screenshots
  • Profile Image

    Answered by victor on September 24, 2015 at 06:12 PM

    Hi,

    Could you please indicate if you are still having this issue. I have clone your form and was able to send a test email that had all 4 fields. I also verified your email notification, to check if it contained all the fields.

    If this occurs, please do not hesitate contacting us and we will take another loo.

    Regards

  • Profile Image

    Answered by jhjuli20152 on September 25, 2015 at 09:59 AM

    Hi,

    The point is that when I insert a new label & answer field in an existing form, the notification is NOT updated. 

    I then have to manually edit the notification (in text mode) before it takes effect.

    As you can see in the pictures. In this case I inserted "Woonplaats".

     

    Regards

     

     

  • Profile Image

    Answered by Ben on September 25, 2015 at 11:38 AM

    The reason why that happens is because you have made a 'dirty' email notification. What this means is that at some point you have made the change to your email notification, and as such our system will not update it any more to make sure that you are only sending the data that you want to send.

    To rectify this, you can simply create a new email notifier instead of the old one and that is it - your email will (as long as it is not changed again) update itself properly for you.

    Hope that this explains why this happens, but please do let us know if you happen to have any further questions and we would be happy to assist with the same.

  • Profile Image

    Answered by jhjuli20152 on September 27, 2015 at 06:46 AM

    ok thanks