What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Encrypted Forms: Textarea inputs are not being decrypted when viewed from the email notification

    Asked by micja on September 28, 2015 at 04:28 PM

    We had a customer submit a form to us completely filled out.  We used our encryption key and some of the form comes through readable, but a lot of it is random characters.  How do we convert the encrypted form?

    The submission we are having problems with came in today 9/28/15 in the account for micja3

    Thanks,

    Michelle

    encryption random characters encrypted private key
  • Profile Image
    JotForm Support

    Answered by jonathan on September 28, 2015 at 05:37 PM

    I checked your jotform http://www.jotform.us/form/52617392332151 , although I can see the submissions data encrypted already, I noticed that it was not set as encrypted on the form itself.

     

    What I suggest you try first is to enable Encrypt Form Data on the form. Set it to Yes.

    This will generate the private key for the encryption.

    user guide: -What-are-Encrypted-Forms-and-how-to-use-them-as-expert

    You can then re-use the private key to unlock the locked form submission data.

    Hope this help. Let us know if this process did not resolve the issue.

  • Profile Image

    Answered by micja on September 28, 2015 at 10:47 PM
    I turned off encryption because we couldn't get all of the info to show
    up on either a windows 10 computer or a windows 7. Every time I try the
    encryption key on the windows 10 computer, this is the error I get:
    registry error snip
    I tried our existing key and a new key.
    Michelle Adams
    Technical Support
    Roznik Media Enterprises
    509-306-7916
    ...
  • Profile Image

    Answered by micja on September 28, 2015 at 11:47 PM
    I have tried my original key and two new keys, and get the same thing
    every time. When I go into jotform.com and view submissions, it doesn't
    ask for the key or apparently use what we had already downloaded for all
    our tests. The whole form is just encrypted. Please tell me how I can
    get this information. I really do not want to go back to our client and
    make him do the whole thing all over again. Please help!
    Thanks,
    Michelle
    Michelle Adams
    Technical Support
    Roznik Media Enterprises
    509-306-7916
    ...
  • Profile Image

    Answered by micja on September 28, 2015 at 11:47 PM
    Now it looks like your whole site is down.

    ...
  • Profile Image
    JotForm Support

    Answered by EltonCris on September 29, 2015 at 05:22 AM

    @micja 

    You can try to re-upload the key again. Since it is currently saved on your browser, the wizard might not popup again when you open the submissions page. I suggest to clear your browsers cache to remove the private key, the encryption wizard should popup after that. Another way is to open private browsing (Firefox) or incognito mode if you're using Chrome.

    There was also a recent update on the form encryption so hopefully this will sort this out.

    Let us know should you have further questions about this. We will answer your concern about the Jotform downtime on this thread http://www.jotform.com/answers/672624.

    Thanks!

  • Profile Image

    Answered by micja on September 29, 2015 at 10:47 AM
    I just tried opening the submission on a completely different computer using Windows 7 and have the same result--none of the comment our larger comments field decrypt. The changes to your encryption must be causing a problem with those fields.
    Sent from Michelle's iPhone.
    ...
  • Profile Image

    Answered by micja on September 29, 2015 at 10:47 AM
    Attempting to open the submission frim an email failed (comments encrypted) on Windows 7 and 10. Opening the submission on Windows 7 from the jot form site account worked. I now have all the information. However it won't work yet on Windows 10 (our whole office) so hopefully this can be fixed.
    Thank you.
    Sent from Michelle's iPhone.
    ...
  • Profile Image
    JotForm Support

    Answered by Charlie on September 29, 2015 at 12:00 PM

    Hi,

    Unfortunately, we're unable to test or replicate the problem that you have because we do not have the key to check your submissions.

    Would it be possible to show us a screenshot of what fields are not decrypted?

    I cloned your form (http://www.jotform.us/form/52617392332151) and tried looking for the problem, I noticed that the fields that are not decrypting properly are those on the Text area field. In my case, when I try decrypting directly on the email notification I received, here are the following field questions that are not decrypting (all of them are textarea field). There's also a part of the Address field that is not properly decrypting.

    If you don't have a domain yet, please let us know and we will help you get one.

    Please add any amenities you have that are not on the list:

    Area Attractions Info or description for each item selected. Add any other attractions such as waterparks

    Additional Comments

    If you like what is written above please say :copy above with these changes:

    Please write about your RV Park

    However, in the submissions page, it decrypts properly. I'm using Windows 10.

    Is this the same properly you are having?

    I made a simple form with an address field and two textarea fields:

     

    In my email notification, I clicked "view response" and this is what's displayed:

     

    I have forwarded this to our developers. We will update you directly on this thread as soon as this has been fixed. Apologies for the inconvenience.