SSL Issue with Facebook Tabs

  • Profile Image
    dotcomUNDERGROUND
    Asked on January 11, 2012 at 05:34 PM

    Hi,

    I am using your contact form over facebook tab. We are using a dedicated app for the purpose.

     

    Here is the setting for the tab:

    http://screen-shot.org/2012-01-12_042620.jpg

    Now when I visit the tab over secure facebook, which should be calling the secure form as the app setting. But its turning off the ssl sign, (as mixed content). And worst of everything, its showing this error when submitting the form:

    http://screen-shot.org/2012-01-12_042510.jpg

     

    I have been using a self hosted form over our own ssl before and did not face any issue like this.

  • Profile Image
    dotcomUNDERGROUND
    Answered on January 11, 2012 at 06:08 PM

    I just wanted to update that I have tried setting ssl form link for both plain and ssl tab link but the result is still the same. Is there any redirection going on anywhere which is sending it to non-ssl form?

     

    We run a lot of self-hosted contents as facebook tabs and never experienced any issue like this before.

  • Profile Image
    fxr
    Answered on January 11, 2012 at 06:30 PM

    Yes, this is odd and only seems to have started very recently. 

    I have confirmed the issue myself with test forms we have on Facebook.

    Our secure forms hosted on JotForm are reporting as using encrypted connections just as before. 

    I know Facebook are rolling out a lot of back end changes this month in their app/developer space, this may well serve as an explanation as to whats has occured. 

    I have escalated this issue to our developers and marked it as urgent.