What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    The Changes are not Applied?

    Asked by ntorrey on December 30, 2015 at 05:15 AM

    For some reason the changes I make to my form are not updating correctly. I can save the changes within the form editor, and if I open the form up again to edit, I see the changes, but when I preview or publish and go to the form's link, the changes do not appear. If I clone the form, the changes ARE saved in the previewed/published form, but any changes made to the new CLONED form aren't saved just as before...hmmm. Any ideas?

    Thank you.

    Page URL:
    https://form.jotformeu.com/53631965522357

    saved changes not saved publish preview not updating Cloned Form
  • Profile Image
    JotForm Support

    Answered by mert on December 30, 2015 at 09:01 AM

    Hi there,

    As you have already mentioned, when I cloned your form, I didn't replicate the same issues. The changes which I made are applied to the preview instantly. Sometimes, this issue could be occur from browser caches or our form caches.

    To beat this issue, you can clear your browser caches or try to do the changes on another browser. In addition, I also deleted your form caches. Please, retry your scenario and let us know the results. Also, please don't forget to save your form after changes. If the first one doesn't work save it twice or more.

     

    Thanks.

  • Profile Image
    JotForm Support

    Answered by mert on December 30, 2015 at 10:14 AM

    Just now, an update came from our developers. On EU servers, we had a latency between servers; but currently, the problem should be fixed. Please, try it again on your side and let us know the results. Also, sorry for the inconvenience.

     

    Thanks.

  • Profile Image

    Answered by ntorrey on January 01, 2016 at 10:24 AM

    Thank you! It seems like the server fix solved the problem.

  • Profile Image
    JotForm Support

    Answered by Charlie on January 01, 2016 at 02:40 PM

    Thank you for the confirmation, we're glad everything is good in your end now. Should you need any assistance again, please do not hesitate to open a new thread here in the forum.