Additional Rows for Conditions have Ceased Functioning

  • Profile Image
    Impacct
    Asked on October 12, 2015 at 11:01 AM

    "Now some of the conditions that update form field values have stopped working.

    I have a condition on page 2 of this form that says if the invoice item is equal to passthrough, enter the amount from the amount cell next to it in the corresponding pass through cell at the bottom. 

    Earlier today, I added some additional rows here, and now the conditions for the new rows are working while the old conditions have ceased functioning. I already checked and confirmed they are not set to clear. 

    Why does this keep happening? I'm finding it hard to believe this is due to an update"

  • Profile Image
    KadeJM
    Answered on October 12, 2015 at 11:17 AM

    Per your other thread with the frozen conditional issue I saw you posted this secondary issue about your additional rows for conditions which have ceased functioning.

    Are you saying it's not sending the passthrough amount with the conditions for all of your fields? Or have I misunderstood you? Please correct or confirm.

    I tried this but after Omur's update I seem to be unable to replicate the problem as of now. 

  • Profile Image
    Impacct
    Answered on October 12, 2015 at 12:15 PM

    Hi Kade,

    Yes, but that part looks fixed now. Now I am just having an issue with the calculation cells at the bottom. 

    The idea is that the Total Fees cell equals the Total Job (this is the total of all amounts) less the Total Pass Through, but that doesn't seem to be working in the test I did just and my users have been complaining about it.

    The total job amount calculation is correct, the total pass through calculation is correct, but the Total Fees Calculation is not working

    It was working just fine, and then suddenly stopped when additional rows were added (which only affects the other 2 calculation cells directly)

    Thanks for your help

    -Ilana

  • Profile Image
    KadeJM
    Answered on October 12, 2015 at 02:05 PM

    Thank you for the correction as I now understand and see what you meant.

     

    I'll need a little bit more time to try to sort this part out since at the moment it is taking me a bit longer than I anticipated for this and i'll let you know in another update shortly.

  • Profile Image
    KadeJM
    Answered on October 12, 2015 at 02:37 PM

    UPDATE -  I believe I have found the problem.

    This happened from when you had modified the fields it changed the Resulting Answer Tags that were associated with it for the Total Pass - Total Job. So it was different from what you had originally and that was the reason as to why it wasn't working.

     

    I've fixed it for you on the updated form - https://form.jotform.com/52843762219965? 

    Feel free to try it again now. 

     

  • Profile Image
    Impacct
    Answered on October 12, 2015 at 02:53 PM

    Your form works, but when I update the calculation on my form selecting the fields from the list shown it does not work. It still thinks 418 & 474 are the total pass through and total job cells.

     

    Why did these indicators update? It would seem that having the indicators for existing fields change when other fields are added/ removed would lead to a lot of problems and forms malfunctioning. Why aren't they coming through correctly in the calculation set up if they were updated?

  • Profile Image
    Mike
    Answered on October 12, 2015 at 04:50 PM

    No, we do not update field {tags}.

    It seems that you have two pairs of fields which are similarly named, and you use the second pair (incorrect) in calculations.

    See the next animation.

  • Profile Image
    Impacct
    Answered on October 12, 2015 at 04:54 PM

    Thank you, that did the trick