Have created a responsive form which will not show on a 480-840 pxl page in Xara

  • Profile Image
    Mikefoto
    Asked on October 13, 2015 at 11:16 AM

    I am trying to load a form onto a web another website version in  Xara Web Designer 11.

    The form functions on the main variant but not in the reduced variant? I have ticked the responsive setting in your options menu, is there something I am missing?

  • Profile Image
    Kiran
    Answered on October 13, 2015 at 01:25 PM

    I'm not sure if I understand your query correctly. Do you mean to say that the form is not responsive to display on your webpages? Are you referring to the form titled Call Back in your account? I've checked the form using direct URL on my mobile and it seems to be working fine. 

    Please refer to the guide below that helps you in enabling responsiveness on your JotForm. 

    http://www.jotform.com/help/311-How-to-make-Forms-Mobile-Responsive

    Also, please go through the thread below that might help you in making the form responsive using xara.

    http://www.jotform.com/answers/587351-How-to-make-form-responsive-on-Xara-Web-Designer-Premium-11

    If the issue still persists, please provide us with the URL of the webpage where your form is embedded so that we can take a look and provide you with necessary assistance. 

    Thanks!

  • Profile Image
    Mikefoto
    Answered on October 13, 2015 at 03:15 PM

    Hi Kiran

    Xara creates more than one variant of a web page, one variant handles 480-840pxls the other, 840-1200 pxls. Your form works nicely on the larger variant but will not display on the smaller variant. I have checked both check boxes in Jot Form, they are ticked to accept responsive websites. I have reloaded and embedded the code into the smaller variant without any success. I am reloading it again and you can look at the test site www.njf.mdephoto.co.za to see the result, on the "Contacts" page.

  • Profile Image
    Kiran
    Answered on October 13, 2015 at 04:44 PM

    I notice that the form is embedded using default Javascript method. I see that the form is disappearing when the size of window is reduced. Could you try embedding the form using iframe embed method to see if that helps. Please go through the guide below to grab the iframe embed code for your JotForm.

    http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code 

    Let us know if you need any further assistance. We will be happy to help.

  • Profile Image
    Mikefoto
    Answered on October 14, 2015 at 02:34 AM

    I have tried the iframe method or code, loads the form into my placeholder fine, but when I preview the page it is not visible. I also tried to activate the share with variants option from the main page and this would not work either.

    I will pose the question to Xara as well

  • Profile Image
    Sammy
    Answered on October 14, 2015 at 09:15 AM

    I did a check of your site, it appears the absolute positioning of the div containing the iframe is causing the form to be placed way above the page resulting in it not being visible at all.

    Could you check the positioning of the elements in your designer for the variant page.

    Do let us know of the outcome from the Xara team.

    I will try to do some test on a copy of the xara designer and let you know if i find a way around the issue.

  • Profile Image
    Sammy
    Answered on October 14, 2015 at 12:12 PM

    You are most welcome, kindly let us know of the outcome on your site pages.

    If you do have any other issues feel free to open a new thread.