Configurable list Required fields not working

  • Profile Image
    lensenj
    Asked on October 14, 2015 at 02:06 AM
    although I have made the configurable list required the user can still blast right past it and hit submit without touching anything.
  • Profile Image
    Chriistian
    Answered on October 14, 2015 at 02:20 AM

    Hi,

     

    I checked your website and noticed that there were conflicts between your website's script and Jotform's. 

     

     Can you try re-embedding your form using the iFrame embed method and see if solves the issue? 

     

    Do let us know if you need further assistance.

    Regards.

  • Profile Image
    lensenj
    Answered on October 14, 2015 at 11:45 AM
    Google sites no longer supports iframe.
    Justin Lensen
    (sent via mobile device, please excuse unclear voice to text grammatical
    errors)
    LA/Riverside Area Manager
    G.B. Sales Floor & Window Coverings
    Corporate Office San Diego
    7720 Kenamar Court, Building A, San Diego, CA 92121
    LA/Riverside Location
    4131 Buchanan Ave, Riverside CA 92505
    (C) 858.805.1979 _ (O) 858.571.3600 x1324 _ (efax) 951.231.9221
    www.gbsales.net
    ...
  • Profile Image
    Charlie
    Answered on October 14, 2015 at 03:03 PM

    For Google Sites, would it be possible to use the Gadget instead? Here's a guide on how to embed the form using the gadget:

    1. First, click the "Embed Form" option.

    2. Choose "Platform", look for "Google Sites"

    3. Follow the instructions mentioned there.

     

    Let us know if that works.

  • Profile Image
    lensenj
    Answered on October 14, 2015 at 08:45 PM
    This is how I have been adding the forms to my sites since the iframe
    discontinuation.
    I am also having the same issue with this form
    https://sites.google.com/site/gbsalesteamterritory/home/installer-supply-order-form.
    I had to remove the required fields on the form as it was preventing the
    page from refreshing.

    ...
  • Profile Image
    Chriistian
    Answered on October 15, 2015 at 12:22 AM

    Hi,

     

    I did some test submission to your form on this site - https://sites.google.com/site/gbsalesteamterritory/blinds-order-form to further check the issue. The Configurable List widget is not validated properly.

     

    I also checked the direct link of the form https://form.jotform.com/52854761299974? and it seems that the issue is also happening on the direct link of the form.

     

    As per further checking, the issue was due to the SELECT value set on the drop down in the Configurable List was considered as it's default value not as empty value. So the field was considered to have a value. To fix this, you need to add the SELECT value on the Hint Text part.

    For example,

    Drop down : dropdown : one, two, three : Please Select

    *Blind Type : dropdown: FAUXWOOD, VERTICAL, PVC MINI : SELECT

     

    You can check this cloned form that I used for testing - https://form.jotformpro.com/52869164847976?

     

    Do let us know if you need further assistance.
    Regards.

  • Profile Image
    Chriistian
    Answered on October 15, 2015 at 12:27 AM

    By the way, regarding to your additional concern on your form from this site - https://sites.google.com/site/gbsalesteamterritory/home/installer-supply-order-form, I have moved it to a separate thread so we ca better assist you. You can check the thread here: http://www.jotform.com/answers/681820. We will attend to it accordingly.