What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form embedded on a website not showing on mobile devices.

    Asked by ywm on October 21, 2015 at 04:16 PM

    Hi there,

     

    I'm using adobe muse to create a website with both a desktop and mobile version. I do exactly what jotform says as far as embedding the form to the site (coping the html to the page in design mode) but when I publish the site to a temporary domain, the same form shows up on the desktop version, but is missing on the mobile version.

     

    How can I fix this problem?

    Page URL:
    http://lees-test.businesscatalyst.com/phone/birthday-club.html

    mobile device embed iframe code embed script
  • Profile Image
    JotForm Support

    Answered by Mike_G on October 21, 2015 at 05:50 PM

    I have checked your website on an android phone your form is showing perfectly on it. 

    What mobile device are you having issues viewing your form when embedded on your website?

    You can try to check if embedding your form using the iframe code will fix the issue. Here's a guide on how you can get the iframe code: Getting-the-Form-iFrame-Code

    Let us know how it goes. We will wait for your response. Thank you.

  • Profile Image

    Answered by ywm on October 21, 2015 at 06:36 PM

    We checked several iPhones and all had the same trouble. The iframe worked, however, so thank you very much!

  • Profile Image
    JotForm Support

    Answered by Kiran on October 21, 2015 at 11:42 PM

    Glad to see that the issue is now resolved for you. I've checked your webpage on an iPhone simulator and it seems to be working fine. 

    Let us know if you need any further assistance. We will be happy to help.

    Thanks!