Can't get JotForm to work with IE11

  • Profile Image
    Rick Tunnell
    Asked on October 23, 2015 at 10:08 AM
  • Profile Image
    Boris
    Answered on October 23, 2015 at 12:58 PM

    I'm sorry to hear about your troubles in using our website, Rick, though we seem to be unable to replicate the issue. I have been able to login just fine over IE 11, and access all the functions without experiencing any issues. Here is a screenshot of IE 11 on My Forms page:

    I have also created and successfully saved a new form as well:

    Could you please let us know which part of our website seems to be failing on your end? Is it the Form Builder, Designer, are you able to see your My Forms page, etc.

    It would also help us understand and try to replicate the issue if you could provide us with a screenshot of the problem. You can attach images to your post by opening this thread directly in the browser, and using the image-shaped icon above the post editor to attach the image. Please refer to the image below for visual guidance on adding an image to your post:

    I couldn't see any issues with using our website over IE 11. We will await your response with more details, so that we can better check the issue that you are experiencing and hopefully fix it for you as well. Thank you.

  • Profile Image
    wllmstrvs
    Answered on November 27, 2015 at 09:39 AM

    I am having the same issue. The Formbuilder and accessing my forms are completely non-functional.
  • Profile Image
    Charlie
    Answered on November 27, 2015 at 12:04 PM

    @wllmstrvs

    Apologies for the inconvenience. To better assist you and discuss this matter, I opened a separate thread for you. Please refer to this link instead: http://www.jotform.com/answers/713074. We will address it shortly. Thank you.