What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Reverting back to an earlier version of the form causes to lose all of the conditions setup?

    Asked by NRCsupport on October 26, 2015 at 08:54 PM

    Form number 40503979576971.

    I made some successful changes yesterday. I've just tried to do more changes, and found that the last edits I did yesterday had disappeared, so I restored a previous version from yesterday. But the restored version has lost all the many conditions on the form. What can I do to get the conditions back?

    Please help, this is urgent.

    Thanks, John

    Page URL:
    IruntheformontheJotFormsite.

    all thanks and to get
  • Profile Image
    JotForm Support

    Answered by Charlie on October 27, 2015 at 01:00 AM

    Hi,

    Have you checked the revision history for the changes you made? I checked them but can't seem to find any changes related to adding conditions to your form. 

    You should be able to see "Form Condition Added" in the history. Here's an example:

    It's possible that your session have ended when you were editing the form. Or if you have opened the form builder in multiple tabs and editing more than one forms, then that may be one reason why the changes are not saving properly.

    I also see that you have a cloned form, please do check if maybe that is the one you have edited.

    I tried to replicate the problem by creating a simple form, adding conditions and reverting back and forth to the form's state where the conditions were removed and added, but was not able to get the problem you are having.

    However, I will still forward this to our developers to check if there were changes made yesterday that may have affected your conditions in the form.

    Apologies for the inconvenience.

  • Profile Image

    Answered by NRCsupport on October 27, 2015 at 01:21 PM

    Hi,

    Thanks for reply.

    It is possible that I had the form open in two windows at the same time (but I doubt it).

    I did do some changes in the cloned form, but the changes were mainly in the actual form. Most of the conditions have been present in the form for many months. I have added and altered a few in the last few days.

    Working backwards through the revision history, the version shown as Today at 00:20 is the latest I can find with the conditions present. I would like to revert to that version, but when I revert to it, and then try to edit it, the reverted version has lost all the conditions. I only know that the 00:20 version has the conditions because when I fill the form displayed in the revision history screen it behaves as it should.

    So reverting seems to lose the conditions. Is there any way to make the 00:20 version become the current version lock stock and barrel rather than going through some process which manages to corrupt it.

    The cloned version is also reasonably up to date, so I could use that, BUT can it be given the original form number instead of the cloned form number? This is because there are several places on our website, and on fliers for our event, where a link to the form is given. Changing the form number in all these places would be quite difficult.

  • Profile Image
    JotForm Support

    Answered by Charlie on October 27, 2015 at 02:44 PM

    Hi,

    I checked your form again (http://www.jotformpro.com/form/40503979576971). In the revision history, I assume you are referring to this version of the form dated 8:20 AM.

    To confirm, the conditions are working and as present when viewing the form in the revision history, however, when you revert to that version of the form, the conditions are not showing or present in the form builder, is that correct?

    I will add it to my bug report to help our developer assigned on this in debugging the problem.

    Apologies for the inconvenience.

  • Profile Image

    Answered by NRCsupport on October 27, 2015 at 08:34 PM

    Yes that is eactly the problem.

    In the reverted form (and all other versions since the form dated 8.20am, when you move from the first page to the second page, an additional panel of text appear at the top of the page above the panel that starts "Barnet/Hadley sponsored walk....". One of the lost conditions controls when that top panel appears, so without the conditions it always appears. At the bottom of the form (below the captcha and submit button there are some hidden fields. The field called "event" contains one of the values "walk", "bbq" and "quiz", and using conditions this determines which of the other parts of the form are shown. In the present tests it is set to "walk". I have only introduced the "event" field and associated conditions quite recently, and was working on the associated changes when all the conditions disappeared, so the logic to do with them is not complete. That superfluous panel should only appear when "event" is "bbq", and therefore should not appear when "event" is "walk"

    I do hope that your developer finds a solution or a workaround urgently, as I am stuck at present. Thanks for your help.

  • Profile Image
    JotForm Support

    Answered by beril on October 28, 2015 at 02:28 AM

    Hi,

    We are sorry for confusion.

    My colleague @Charlie forwarded this issue to our developers. We will inform you as soon as possible, when we solve the problem.

    Thank you for your understanding.

    If you have any question or issues, please do not hesitate contacting us. We will be glad to assist you.

  • Profile Image

    Answered by NRCsupport on October 28, 2015 at 05:02 AM

    Thanks.

    Do you think that a solution is likely in the next 24 to 48 hours? If not, do you have any suggestions of a work around? Or do I need to try to recreate all my conditions?

  • Profile Image
    JotForm Support

    Answered by Charlie on October 28, 2015 at 05:39 AM

    Unfortunately, I'm unable to give an estimated time frame for this. This is assigned on a different team and they are still currently looking at it.

    The developers are investigating your form, I believe recreating the conditions would be best so that you can continue working and finishing the form. Perhaps you can continue working on the cloned form instead while waiting for the issues in the original form to be fixed.

    Apologies if this is causing an inconvenience in your current work progress.

  • Profile Image

    Answered by John (NRCSUPPORT)  on October 28, 2015 at 07:20 AM

    OK, thanks. I've started recreating the conditions. I am NOT able to work on the cloned form, as I need to keep the form number/url the same. Otherwise I would have to do a lot of work on other parts of my website.

    I look forward to hearing of any progress.

    John

  • Profile Image
    JotForm Support

    Answered by beril on October 28, 2015 at 07:44 AM

    Hi john,

    I told this issue to our developers. They are trying to fix this issue now. We will let you know, when there is an update.

    Thank you.

  • Profile Image

    Answered by NRCsupport on October 28, 2015 at 08:01 PM

    Hello again.

    I've just found that all the response and notification emails have disappeared as well.

  • Profile Image

    Answered by Shadae on October 29, 2015 at 04:48 AM

    HI NRCsupport,

    Thank you for bringing this additional information to our attention. I have updated your ticket to reflect that.

    Once there is an update on the issue it will be posted to this thread.

    Please feel free to contact us if you need further assistance.