My JotForm is not working or loading in any Internet Explorer browser.

  • Profile Image
    Maylan
    Asked on October 27, 2015 at 12:37 PM

    My JotForm is not working or loading in any Internet Explorer browser. Please correct the issue of JotForm loading on IE. Here's the URL: http://firstfamilycare.com/make-an-appointment.html

     

    Thank you.

  • Profile Image
    EltonCris
    Answered on October 27, 2015 at 01:08 PM

    Hello Maylan,

    I was able to reproduce the problem on internet explorer. I will escalate this to our developers so they can check and investigate this further.

    For now, here's a solution that would prevent this from happening on IE. Simply re-embed your form using the following iframe embed code without its script code.

    <iframe id="JotFormIFrame" src="https://form.jotform.com/52974523948166" frameborder="0" scrolling="no" style="border: none; border-image: none; width: 100%; height: 1500px;" allowtransparency="true" onload="window.parent.scrollTo(0,0)"></iframe>

    Hope this helps!

  • Profile Image
    EltonCris
    Answered on October 27, 2015 at 01:17 PM

    Update: The form embedded using iframe on a clean HTML seems working fine on internet explorer https://shots.jotform.com/elton/testIFrameHeight.html. I think something from your website script is conflicting the script included in iframe embed code. This results to cut off or incorrect iframe height of the form. However, the solution I provided above should work better for your form. Thanks!

  • Profile Image
    maylan007
    Answered on October 28, 2015 at 08:27 PM

    Thanks for the reply and help. I did reembed the form as you asked, copied and pasted the above in the html, css part of the form in my website code, but still there is no difference in Internet Explorer. Again, it opens excellent in Google Chrome, but on IE it starts to load, then cuts off. Can you please try to help me again to resolve this?

    Thank you.

  • Profile Image
    EltonCris
    Answered on October 28, 2015 at 11:44 PM

    Maylan, 

    I can still see the script included on the iframe embed code on your webpage. I suggest to replace it again with the following, this has min-height so this should prevent any cut off on IE browser.

    <iframe src="https://form.jotform.com/52974523948166" frameborder="0" scrolling="no" style="border: none; border-image-source: none; width: 100%; height: 1500px;min-height:1500px;" allowtransparency="true"></iframe>

    Thanks!

  • Profile Image
    maylan007
    Answered on October 29, 2015 at 11:02 AM

    Thank you so much! It's been fixed! Thank you for the help!

    -Maylan

  • Profile Image
    Mike_G
    Answered on October 29, 2015 at 02:10 PM

    On behalf of my colleague, Elton, you're most welcome. Feel free to get back to us if you have any concerns and we will be glad to help you. Thank you.