Form Emails unable to receive

  • Profile Image
    George 
    Asked on October 29, 2015 at 07:12 AM

    Hi there,

     

    I've just set up a form with you (https://form.jotformeu.com/53012610926345) but nothing seems to happen when I click submit - I've set up emails etc, but nothing seems to come through. Is it because it takes a while, or have I done something wrong?

     

    Thanks 

     

    George

  • Profile Image
    Chriistian
    Answered on October 29, 2015 at 11:11 AM

    Hi George,

     

    I checked the recipient of the Notificaiton email of your form - http://www.jotformeu.com/form/53012610926345 which is your account's email address george@belltent.co.uk. I checked the mail log of the form and it seems that the emails are sent successfully even the test emails.

     

    You can also check your form's email history on your end. For more information, you can check this article: How to view all your form Email History. Can you try again a test submission in your form and see if you will receive it now?

     

    We will wait for your response.
    Regards.

  • Profile Image
    georgejeffery
    Answered on October 29, 2015 at 11:45 AM
    Hi Christian,

    Thanks for your response! I’m getting the test emails through, but none of the actual form submissions are coming through.


    Kind Regards,

    George
    Sales Team
    07830355993

    ...
  • Profile Image
    KadeJM
    Answered on October 29, 2015 at 12:56 PM

    We do sincerely apologize about this issue and inconvenience. Our Developers found and fixed and issue with emails being sent by users on our EU Servers. Please test this again on your end and do let us know if you are still having any sort of issues.

  • Profile Image
    zeichenmanufaktur
    Answered on October 29, 2015 at 01:06 PM

    No, it´s not fixed. I am very sorry. Just tried it.

  • Profile Image
    KadeJM
    Answered on October 29, 2015 at 02:27 PM

    I understand and thank you for the update about that.

    Are you using the Test Email Button or are you filling in your form and submitting it to yourself?

    It seems to me that according to your Email History you have 1 submission that was standard and the rest are tests from using the test button.

    I would suggest filling in your form and submitting it to yourself to test it more accurately if you haven't done so yet and let us know.

  • Profile Image
    georgejeffery
    Answered on October 30, 2015 at 05:45 AM
    Hi,

    I’ve tried filling the form out, and I’m not getting a response. The test emails were working fine.


    Kind Regards,

    George
    Sales Team
    07830355993

    ...
  • Profile Image
    Charlie
    Answered on October 30, 2015 at 09:49 AM

    We are very sorry for the inconvenience. We have alerted our developers about this problem, it seems like it is isolated to users that are in the EU region. We hope that this will be fixed as soon as possible.

  • Profile Image
    Charlie
    Answered on October 30, 2015 at 01:50 PM

    Hi,

    We have received reports from our developers that this issue has been fixed.

    Please do let us know if the problem persists in your end.

    Thank you for your patience.