What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Google Sheets integration never finishes / works

    Asked by slars0n on October 31, 2015 at 05:15 PM

    Hi,

       I've been trying to do google sheets integration with my form, but it just endlessly says it is working but it never happens.  Can you help?

     

    Thanks,

      Stephen

    google spreadsheet
  • Profile Image
    JotForm Support

    Answered by jonathan on October 31, 2015 at 07:16 PM

    Hi Stephen,

    Can you provide us more details on the issue. 

    Were you able to successfully integrate the form?

    You can know this when you click on Integration in the Form Builder and you can see a check marked on the applications currently integrated to the form.

    I just test it on my test form and Google spreadsheet integration work fine so far.

    Please retry also re-integrating after removing the previous integration. Let us know if this process still did not resolve the issue.

     

    Thanks.

  • Profile Image

    Answered by slars0n on November 01, 2015 at 12:45 PM
    Still no luck. Basically I get to this step:
    [image: Inline image 1]
    And it does this forever -- even an hour later there's nothing. If I
    reload the page, there is no existing integration, it just starts over from
    scratch.
    I'm using a google apps for business account if it makes any difference.

    Stephen D. Larson, Ph.D
    Chief Executive Officer
    MetaCell
    347-878-3679
    http://metacell.us
    ...
  • Profile Image
    JotForm Support

    Answered by jonathan on November 01, 2015 at 03:29 PM

    We are not able to see the screenshot/image you tried to share in your last response.

    Please resend it again. Follow this steps

    ------------------------------------------------------

    1. Click on Insert/Edit image button

    2. Click on the "Upload" button

     

    3. Click on Choose File and look in your local folders.

    4. Click on Submit

    =================

     

    I just checked on your lone form http://www.jotform.us/form/53025623666152 and I noted that it was indeed NOT integrated to Google Spreadsheet.

    One thing I can suggest also is to make sure you are also logged in to your Google account and at the same time logged in to the Form Builder when doing the integration.

    We will wait for your updates

     

     

  • Profile Image

    Answered by slars0n on November 01, 2015 at 04:12 PM

     

  • Profile Image
    JotForm Support

    Answered by jonathan on November 01, 2015 at 05:58 PM

    Thank you for providing the screenshot.

    I was able to understand and reproduced the issue now when I actually test it using your jotform http://www.jotform.us/form/53025623666152

    I have forwarded this thread to our higher team support to check on the glitch on your form integration to Google Spreadsheet.

    We will notify you here once fixed.

    Sorry for the inconvenience caused.