Unable to register new account

  • Profile Image
    Manuel 
    Asked on November 03, 2015 at 05:40 AM

    Hi,

     

    I was trying to create an account since last week but everytime I get to your landing page, its seems its down (is it shows in the sceenshot I've just uploaded).

    Can you please help?

     

    Best,

    Manuel

  • Profile Image
    Jan
    Answered on November 03, 2015 at 09:27 AM

    We are not having any issues with our website currently. I was able to access our webpage properly.

    I can see what you mean. When that happens, please try refreshing the page. Normally, refreshing the page should fix the problem.

    If it is still the same, then please try disabling the browser add-ons or extensions. If no go, then please try to use another browser and see if it works. If you're still having issues then please try using wired connection instead of wireless.

    Also, here's the link where you can sign up for new account: http://www.jotform.com/signup

    Hope that helps. Thank you.

  • Profile Image
    Manuel 
    Answered on November 06, 2015 at 10:45 AM
    Hi,
    Thanks for the reply.
    So I have tried it all (except for a wlan connection that i have no access
    to) and I still see the same issue. Even using another browser (see
    attachment).
    Is there anything else i can do?
    Thanks
    [image: Inline image 1]
    [image: photo]
    *Manuel Pina*
    Operations Manager Porto
    e:manuel.pina@uber.com | w:www.uber.com
    /porto
    50+ countries and counting...
    ...
  • Profile Image
    Kiran
    Answered on November 06, 2015 at 12:35 PM

    We are very sorry for the inconvenience this may have caused. By any chance, are you using any any antivirus software on your system like Trend Micro? We have noticed some false positives with Trend Micro blocking JotForm CDN. Please try adding jotform.com domain in the whitelist of the anti-virus software and see if that helps.

    Also, please try accessing the website using the following URL and check if the page is loading fine.

    http://www.jotform.com/?nocdn=true

    Please do not hesitate to get back to us if the issue still persists. We will be happy to help.