Google Drive Integration does not create subfolder correctly

  • Profile Image
    MyPowerSports
    Asked on November 03, 2015 at 06:48 AM

    My form has an integration with Google Drive enabled.  The submissions show up in the Google Drive Folder but the Submission Id does not display in Folder Name or File Name that JotForm creates in the Drive Folder.  This is what it creates "{Submission Id}"  I have also tried the Submission Time field with the same results. It appears this data is not getting passed through. 

    Also, Is there a way to have it create all the form submissions in one folder? Currently each submission gets it's a new folder with the .pdf inside it.  

    Thank you for your help.

     

  • Profile Image
    victor
    Answered on November 03, 2015 at 10:19 AM

    Sorry for this inconvenience. Could you please try to re-integrate google drive to your form. I have just integrated and was able to create a subfolder with the field required

    To keep it organized Jotform was design to create a subfolder for each submission. If you try to use the same subfolder, you have a change of losing data. Submission with same name could be over written.

    Please let us know if this helps.

  • Profile Image
    MyPowerSports
    Answered on November 03, 2015 at 11:33 AM

    Victor, Thank you for the quick reply.  My Integration interface looks different than yours.  I have attached a screen shot.  I do not see a way to pick the Main Folder of the Sumbission folder name.  

  • Profile Image
    victor
    Answered on November 03, 2015 at 01:14 PM

    Sorry I am still using the old integration wizard. :)

    Using the new wizards, you can modify the folder names by pressing the pencil icon.

    Please let us know if you require further assistance.

  • Profile Image
    MyPowerSports
    Answered on November 03, 2015 at 01:33 PM

    OK, I understand how to modify the folder names.  The form appears to not be passing the {Submission Time} data  to Google Drive.  All of my folders start with "{Submission Time}" and not the actual submission time.  Any advice?

     

     

  • Profile Image
    victor
    Answered on November 03, 2015 at 03:32 PM

    Sorry for this inconvenience. I was able to get the submission time in the subfolder, but did notice that there is an issue with this.

    It seems that the first field used in the subfolder is nor being captured correctly. If you place {fullname} - {Submission TIme}, you will notice that the fullname is not capture.

    I have forward this to our back end team. They are currently working on the issue and we/ll get back to you as soon as this is resolved.

  • Profile Image
    MyPowerSports
    Answered on November 03, 2015 at 03:47 PM

    Thank you Victor!

     

  • Profile Image
    victor
    Answered on November 03, 2015 at 05:47 PM

    You are welcome. We will update you as soon as possible.

  • Profile Image
    deniz
    Answered on November 06, 2015 at 02:19 AM

    Hi,

    This problem has been resolved.

    Thank you for your patience.