Form will not submit

  • Profile Image
    dhurdle
    Asked on November 03, 2015 at 12:22 PM

    HI

    I emailed a while back and I received a response that my form was working fine.  It still does not work for me or for my clients.  I have had to use an alternate source to get my forms signed.  It is my contract 2014 and once you hit submit it just says please wait and never goes through.  I have let it sit for hours to see and it doesn't work.  Any help would be appreciated more than it works for us.....

  • Profile Image
    david
    Answered on November 03, 2015 at 03:18 PM

    Hi,

    I cloned your form to test it and I was able to send several submissions through without issue.  I send a test submission through your embedded form and that went through as well:

    You can try replacing your current embed code with the iFrame code to see if that will help:

    http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    Also, let us know if the non-embedded form works or if the error persist even when it is not embedded.  As far as I can tell though, the form should indeed be working.

  • Profile Image
    dhurdle
    Answered on November 03, 2015 at 03:45 PM
    I tried to open it in the jot form website and still can’t get it to go through. I’ve had 4 clients that have not been able to get it to work either. They are going through my website. I can see that you can get it to go through but mine was still saying please wait since I sent the original email….Could it be not compatible with Mac anymore? Not sure what my clients are using but I only have mac computers. We have tried on iPad and phones also with no luck. I will try replacing the code to see if that works. All of my other forms are working its just the contract that doesn’t work.
    Denise
    Denise Hurdle
    Denise Hurdle Photography
    949.395.6502
    www.DeniseHurdlePhotography.com
    info@denisehurdlephotography.com
    ...
  • Profile Image
    david
    Answered on November 03, 2015 at 04:49 PM

    Try the iFrame embed and try the form itself when not embedded.  The form should be mac compatible but should work much better on ios devices when using iFrame embed method.  One more question, does the form work when no payment options are selected or does it still fail to submit even when no products are selected?

  • Profile Image
    dhurdle
    Answered on November 03, 2015 at 05:45 PM
    just tried without the payment and it works…..I just rechecked all my settings in the payment part and they seem fine. The last contract I received with payment was Sept 13th.
    Denise Hurdle
    Denise Hurdle Photography
    949.395.6502
    www.DeniseHurdlePhotography.com
    info@denisehurdlephotography.com
    ...
  • Profile Image
    Kiran
    Answered on November 03, 2015 at 11:17 PM

    I've tried cloning your JotForm to my account and it seems to be working fine with payments as well. As I tested your JotForm, I'm able to replicate the issue when an option from payment is selected and able to submit the form without selecting any option in it. It looks like there is an issue with the payment tool on your JotForm. Could you please try removing the Payment field and add it again following the steps below :

    1. Open your JotForm in edit mode

    2. Remove the payment tool by clicking X icon on the field

    3. You'll be prompted to keep the products if you want to add another payment tool. Click on Yes

    4. Now, add Stripe Payment again from the Payment tools. You should be now having the payment tool with the products added automatically.

    5. Connect your Stripe account with the Payment tool and complete the wizard.

    6. Save your JotForm. 

    Please test the form and let us know if the issue still persists. We will be happy to take a look again.

    Thank you!!