What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Email Notification not populating field values on subject line

    Asked by otabo on November 10, 2015 at 03:12 PM

    Hello, thank you for your help so far. We tried everything from the following screenshots and still need help!

    Each time we try to customize the subject line, we experience issues with the referenced fields in the subject line as well as in the body of the email. 

    For now, we have only included "company name" in the subject line, but it seems like the code for these fields has become corrupt. Is there any work around?

    Below screen shot was supposed to be "Trade Inquiry: {company name} / {whatFootwear7} / {inquiryValue16}", as you can see, there are simply blanks where the second two fields should be referenced. 

    The missing information from certain fields in our email notifications can all be found in our jotforms submission history, but we need the information to be included in our email notifications too.

     

    Looking forward to your email at arthur@otabo.com, or if it will lead to a faster solution I would love to set up a phone call.

     

    best,

    Arthur

    Page URL:
    http://otabo.com/pages/shoe-manufacturer

    Screenshot
    fields on subject field on header
  • Profile Image
    JotForm Support

    Answered by Kevin_G on November 10, 2015 at 06:19 PM

    Hi Arthur,

    Thank you for contacting us.

    I was unable to replicate your issue,I've cloned one of your forms, but I don't know if it is with you are getting the issue  : 

    http://www.jotform.com/43285655166967

    This is the result in my email notification : 

    If the form with I'm testing is not with you are getting the issue, share us the correct link to your form, we will be glad to make further tests and solve it.

    Thanks.

  • Profile Image

    Answered by arthur_otabo on November 10, 2015 at 10:09 PM

    Thanks. 

    I had included a link to the form that is currently giving us problems. http://otabo.com/pages/shoe-manufacturer , its called "trade inquiry" in our jotforms form, its the one with the most submissions.

     

    The reason no one on your end can "replicate" it, is that the issue is only occuring in the email that is being sent to us after the client submits the form. The information is being successfully saved to jotforms, and we can see the information there, but there is some sort of bug going on with the fields in the email.

    We have tried many times to re-create this email, and tried different combinations of the field code in the subject line (also still not working).

    Do we need to re-draft and publish this form?

    Can we change the code names of different fields in their settings? 

    Please help recommend other work arounds, as the issue is not resolved and we have already gone in circles with JotForm standard operating troubleshooting procedures.

     

    best,

    Arthur

     

     

     

  • Profile Image
    JotForm Support

    Answered by EltonCris on November 11, 2015 at 03:53 AM

    Hello Arthur,

    Base on the email log from your previous notifications, there seems missing with the variable in your notification subject header, it is missing a closing tag on the 3rd field variable that's why the data was not properly populated on the header.

    So I went ahead and cloned your form then I edited it with the tags as per your description.

    Inquiry: {companyName}/{whatFootwear7}/{inquiryValue16}

    And this is what I've received after performing a test. 

    I suggest to add those field variables again or you can copy the one I've placed above and then perform a test. It should work just fine. If you also want us to submit a test, let us know so we can further help.

    Do we need to re-draft and publish this form?

    No this isn't necessary, your form should work as it should

    Can we change the code names of different fields in their settings? 

    Yes, you can do this but you must also update the field variables on the notification as well as on the header.

    Thanks!

  • Profile Image

    Answered by alexandra_otabo on November 11, 2015 at 12:13 PM

    Hi Elton,

    The lack of a closing tag was not the issue. You are referencing a mistake made in a test notifier we did. Upon further inspection, you will notice that our notifier is no longer formatted that way. This problem existed prior to the test you are mentioning.

    "Can we change the code names of different fields in their settings? 

    Yes, you can do this but you must also update the field variables on the notification as well as on the header."

    The above does not answer whether or not this might help us, only that we can change the names, which we already knew.

    We have tried all of the advice given to us and, despite JotForm employee test results producing the intended effect, ours do not when we follow your instructions or perform further tests of our own.

    I would ask that we get forwarded to Tier 2 support if that is possible, since so far our actual problem has not been addressed or solved. If this is simply user error, I am willing to accept that, but it does not seem like that is the case here.

    Starting from the beginning,
     
    Our Problems:
    1) Fields filled out by inquirers which show up on JotForm are not showing up in the emails we receive from JotForm (specifically "Inquiry Value," "How many styles do you want to produce" and "What footwear category does your design fit in?") See examples under "What we have tried" from our tests.
     
    2) Email Subject line fields are not populating. We have temporarily taken out the code for these extra fields, but they need to get put back in. We have tried to re-add them many times but information in the subject line beyond "Company Name" will not show up.
     
    "Inquiry: {companyName} / {whatFootwear7} / Order Value: {inquiryValue16}" produces this:
     
     
    What We Have Tried:
    1) We have tried to alter the original notifier we were using before this issue started to make sure body text and form fields matched with no discrepancies. This did not work.
     
    2) We have created a new notifier from the one Jotform automatically creates. With this method, the information mentioned shows up in JotForm but not in the emails:
     
    3) We have created a new notifier manually, by creating a table and filling out the form fields. With this method, the information mentioned shows up in JotForm but not in the emails:
     
    Again, our problem has not really been addressed yet. We have spent several days trying to fix the issue ourselves, the above examples being only some of what we have tried. This should not be the case.
     
    Please review the actions we have already taken and let us know a better option for getting this issue resolved.
     
    Best,
     
    Alex
  • Profile Image
    JotForm Support

    Answered by BJoanna on November 11, 2015 at 02:29 PM

    I have created Email Notification on your form and added "Inquiry: {companyName} / {whatFootwear7} / Order Value: {inquiryValue16}" as Subject of Notification. 

    After that I have submitted your form and Notification that I received looks like this.

    Can you please change email address on Notification that I created and test if you are going to receive all data?

    Looking forward to your reply.

     

  • Profile Image

    Answered by arthur_otabo on November 11, 2015 at 02:34 PM

    I think to test this, you need to fill out the live form from our web page, the tests are not replicating the same bug that we see by completing tests within jotforms. 

     

    -art

  • Profile Image

    Answered by alexandra_otabo on November 11, 2015 at 02:52 PM

    Hi, 

    I changed the email address on the notifier you created. Formerly missing fields in body text of email are coming in:

    (Any ideas on what was done differently here from our tests?)

    Fields in the subject line are not:

     

    Best,

    Alex

     

  • Profile Image
    JotForm Support

    Answered by EltonCris on November 11, 2015 at 04:23 PM

    On the Trade Inquiry Test Form there's an invalid company field variable, it should be {companyName} not {companyName10}. I have updated it and it started to work.

    However, on your live form, I've made an actual submission on the form embedded in your website here with my email as one of the recipients and I was able to reproduce the problem.

     

    Now, I suspect that the problem lies on the embedded form version on your page. I suggest to retake your updated form source code and re-embed it on your page. I think this would help. I have tried this as well and it worked for me after using the updated form source code. 

    Hopefully, it's just a problem with the source code version that needs to be updated. Otherwise, it could be something else. There might be something that is interrupting those fields to appear on email.

    We'll await your updates. Thanks!

  • Profile Image
    JotForm Support

    Answered by EltonCris on November 11, 2015 at 04:34 PM

    Update:

    So I used the form source code version in your site and replaced it with my cloned form ID and it is indeed not populating the field values on the subject line. But, after I retake the form source code and update the file, it works like a charm. However, we'd like to know how this goes on your side as well. Thanks!