My background image is not appearing online, but it does appear in the designer. How do I fix this?

  • Profile Image
    cdlong
    Asked on November 12, 2015 at 07:23 PM

    I created two forms that use this background image: http://www.wilsonlegalsol.com/media/background.jpg. When I specify it in the designer, it appears, but when I view the forms online, they do not. Any suggestions how to fix?

    https://form.jotform.com/53126127954153

    https://form.jotform.com/53125625360146

     

    Thank you.

  • Profile Image
    EltonCris
    Answered on November 12, 2015 at 11:04 PM

    It is because the background image is in your server and your server does not support https, that's why the image is now loaded. https://www.wilsonlegalsol.com/media/background.jpg. Your background image will only load on non-secure forms at the moment http://form.jotform.com/53126127954153.

    I suggest uploading your background image in the background image section in the form designer so the file will be hosted at Jotform. This should not have any problems.

    Hope this helps!

  • Profile Image
    cdlong
    Answered on November 13, 2015 at 07:31 AM

    Thank you - that worked. I realized that was the problem after seeing some other answers, but I couldn't see how to upload the file to Jotform while my image link was still in the form field. I had to delete it to reveal the instructions. Thanks again.

  • Profile Image
    EltonCris
    Answered on November 13, 2015 at 08:09 AM

    Yeah you're right, it has to be deleted to reveal the upload button. :)

    Glad to be of help. Cheers!