Authorize.net Submission made, but no charge was made nor notification of payment was received

  • Profile Image
    NTSRD
    Asked on November 18, 2015 at 11:25 AM

    I TESTED MY FORM AND I HAVE NOT RECEIVE PAYMENT NOTIFICATION YET? I ALSO DON'T SEE THAT MY CARD WAS CHARGED.

  • Profile Image
    Ben
    Answered on November 18, 2015 at 12:41 PM

    Seems that you have deleted the form, but it was just after I opened it to check it out so I was able to check it a bit.

    Please do note that if you do not select any fields on your payment tool of your form, then the payment will not be required nor made.

    It should however charge your credit card as soon as you select one of the payment options.

    You can see more about setting up the Authorize.net payment tool here: How to Test Authorize.net Payment Tool on Sandbox Mode?

    Once you set it up and test in the sandbox, you will be able to see all the details as they happen allowing you to simply switch to live mode and use your form.

    Do let us know of course if you happen to have any issues along the way and we would be happy to assist with the same.

  • Profile Image
    NTSRD
    Answered on November 18, 2015 at 01:45 PM

    I created a new form and am having the same problem still.

    ...

  • Profile Image
    Ben
    Answered on November 18, 2015 at 03:13 PM

    I see this form in your account: http://www.jotform.us/form/53214878298165

    Now based on what I see, it seems to behave properly.

    Can you please tell us what happens when you submit the form?

    Your submissions should also cause your credit card to be charged, but to see that, it is best to log into your Authorize.net account and check for new customers, but under the subscriptions as well.

    Once there, you should see the entry there.If you do not, please do let us know and we would raise this to our developers.I will also try clearing your form cache to make sure that it is not the one that is causing this for you.

  • Profile Image
    NTSRD
    Answered on November 18, 2015 at 03:16 PM

    nothing happens inside of authorize.net. I receive a notification from JotForm that a form was submitted. Nothing is being transferred to authorize.net.

  • Profile Image
    BDAVID
    Answered on November 18, 2015 at 04:51 PM

    I just tested the Authorized.net payment integration in Sandbox mode, and I receive the notification that the transaction was received:

    I also checked on Authorize.net end, and it shows there:

    I would recommend you to create a new transaction key, and integrate again: https://support.authorize.net/authkb/index?page=content&id=A682

    Let us know if you need more help, we will be glad to assist you.