My Condition is not working as expected

  • Profile Image
    mgcaledonian13
    Asked on December 02, 2015 at 05:41 PM

    I have a condition that appears to not work as it should.

    On the form there is a field that requires the number of passengers in a car and when the "confirmation" with the cost is selected the condition shows that there is an error field (mismatch in number) when another selection is made it does show that there is a mismatch as expected then if the correct selection is made the error is  hidden as expect and the Submit button appears again as expected

    Is there a conflict in the conditions? I have checked numerous times and I cannot find a conflict at all.

    Your assistance would be of help on this.

    This form is not in use yet 

    Willy Scott  

  • Profile Image
    EltonCris
    Answered on December 02, 2015 at 08:37 PM

    There is indeed conflict with your condition particularly on the show error message part.

    Here's my cloned version with a simplified setup and conditions. I think this works better for you.

    https://form.jotform.com/53358299344971?

    Feel free to clone this form so you can view the setup and use it if you like.

    Hope this helps!

  • Profile Image
    mgcaledonian13
    Answered on December 04, 2015 at 05:55 PM

    I am afraid that you missed the point of what I was trying to do.

    But, not to worry I got the problem solved by deleting all the conditions that referred to the effect I was trying to achieve. Then I went through conditions carefully, job done.

    Thanks anyway  

    Willy Scott 

  • Profile Image
    Welvin
    Answered on December 05, 2015 at 03:57 AM

    That's great to know. Please contact us again if we can help in any way.