HTML codes for the auto responder email aren't being rendered

  • Profile Image
    sjreynolds
    Asked on December 04, 2015 at 08:31 AM

    Hey,

     

    Just set up an auto responder in html mode, but the email isnt rendering, just coming out at garbled html.

    Can provide the code I'm using but I've attached a screen shot of the output and input

     

     

  • Profile Image
    victor
    Answered on December 04, 2015 at 10:30 AM

    Sorry for this inconvenience. I cloned your form and did notice the HTML code in your AUTORESPONDER. Could you please delete this notification and re-create it. Once I did this, I was able to view the notification properly.

    If you still require assistance, please let us know. We will be glad to take another look.

  • Profile Image
    sjreynolds
    Answered on December 05, 2015 at 04:22 AM

    Hi sorry, but what are the steps you want me to take?

     

    Clone the form?

    Delete and recrete the autoresponder?

     

    Doing the second yeilded the same result - the html is just being sent as code, and not being rendered.

  • Profile Image
    Welvin
    Answered on December 05, 2015 at 08:32 AM

    Please do the following:

    Delete your notifier/auto responder emails: https://www.jotform.com/help/132-How-to-Delete-Notifications-Autoresponder.

    Here's how to create the notifier: https://www.jotform.com/help/25-Setting-Up-Email-Notifications.

    Here's how to create the auto responder email: https://www.jotform.com/help/26-Creating-a-Form-Autoresponder.

    I've checked your form notifier and the HTML is rendered correctly:

    If you want, we can do it for you. But to fix it, please check if your firewall or any sort of blocking apps/extensions aren't causing it. 

    Let us know if you need any further assistance.

  • Profile Image
    Welvin
    Answered on December 05, 2015 at 08:39 AM

    I'm sorry. I just noticed your screenshot after posting my reply. Based on your screenshot, it seems like you would like to add an HTML source into the autoresponder email. In order for the HTML to render correctly, you will have to paste it in the SOURCE codes editor.

    Click the Source Codes icon <> in the notifier and paste the HTML in the popup window. Please follow this visual guide: 

    If you need some help, you can send the source codes to support@jotform.com and let us know so we can do it for you. You can use http://www.pastiebin.com to paste the source and send it to email.

    I hope that helps.

  • Profile Image
    Welvin
    Answered on December 05, 2015 at 08:41 AM

    But allow me to add that there's a chance that some of the elements in the source codes will be stripped out in the autoresponder email. The source codes can only accept inline styles and then tables. Please try it and let us know if there are problems.