Can I use a Link into the Element Value?

  • Profile Image
    gbrchagas
    Asked on February 01, 2012 at 09:58 AM

    Hello Friends!

    I'm trying to put a link into the element of a hidden field. Because i need to show the link into a field in a Grid Report.

    But no sucess. Would be very usefull if it worked.

    Any idea how can i solve this?

    Thanks!

  • Profile Image
    abajan
    Answered on February 01, 2012 at 12:32 PM

    Tests I have run show that the double-quotes (" ") enclosing the URL need to be changed to single-quotes (' '). However, there's another hurdle that needs to be overcome: The submission ID variable {sid} in the said URL is not converted. In other words, while links can be inserted, the purpose for which you want to use that specific link won't work because the {sid} tag will not be converted to the actual submission ID. Instead, the opening and closing braces of the tag are automatically converted to their percent encoded equivalents (percent7B and percent7D) and the content remains unchanged: sid.

    To better understand my point, clone this edited version of your form, change the recipient address in its notification from user@example.com to your email address, change the form ID in the hidden field's link to the new ID, save the change, go to the form's URL, complete and submit the form. When you check either the notification or the form's submissions page, you'll see that even though the link is there, it doesn't work correctly.

  • Profile Image
    gbrchagas
    Answered on February 03, 2012 at 09:55 AM

    You are right.

    The link works only with single-quotes but not with ID on url, and this way will never work.

    And now i understand why...The {sid} not exist yet when i submitted the form, it's generated at this time so it's impossible to pick him in this moment. Right?

    Well, no problem, i already acept the fact.

    Thanks for the help anyway! =)