What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    When I input data in form fields, form starts to hang.

    Asked by wolfpaw69 on December 14, 2015 at 10:18 AM

    My form started hanging up.  When I go to enter any data, I get the "...long-running script" error.  This is during a preview window.  Only happens in IE-11 but works in Firefox.  Cleared all the history, problem continues.

    Page URL:
    http://www.jotform.com/?formID=53127112452141

    Screenshot
    Long problem preview all
  • Profile Image
    JotForm Support

    Answered by ashwin_d on December 14, 2015 at 12:49 PM

    Hello wolfpaw69,

    I did check your form and I am able to replicate the issue you are having. I did performance test of your form and it seems there are reasons which is causing this delay. Please check the analysis report here:  https://gtmetrix.com/reports/www.jotform.us/BWm67BSK 

    It seems you have several images in your form which is taking time to load. You also seems to have "Auto Fill" setting in your form enabled which is also adding to the load time. You have 97 fields and input data of all fields will be written to cookies.

    I would suggest you to disable the "Auto Fill" feature and also remove some images (or use some low resolution images). That should dramatically improve the performance of your form. 

    Do try it our and get back to us if the issue persists.

    Thank you!

  • Profile Image

    Answered by wolfpaw69 on December 15, 2015 at 02:46 PM

    Interesting.  Its working now.  I didn't do anything to the form.  I have one real photo and 6 photos that are just a line.

  • Profile Image

    Answered by victor on December 15, 2015 at 03:31 PM

    Glad to hear the good news. If you experience this again, please let us know and we will be glad to take another look.

    Have a great day.

  • Profile Image

    Answered by wolfpaw69 on December 17, 2015 at 11:36 AM

    Still hangs up in IE but not in Google.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on December 17, 2015 at 12:03 PM

    Hello wolfpaw69,

    I did check your form in IE and it does seems to take sometime to load but works fine in chrome and firefox.

    As suggested earlier, can you please disable the "Auto Fill" setting of your form and see if that solves your problem. 

    We will wait for your response.

    Thank you!