What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Not all Form separator widgets displaying on a form

    Asked by AirtexDesignGroup on December 23, 2015 at 04:15 PM

    I am working on this form:

    https://form.jotform.com/53513952560960

     

    I am using form separators to break up sections on my form. But only 2 or 3 at a time will actually display. I have tried reinserting some of them with no success. I am using Chrome and I already checked to make sure it was up to date. Is there any way to resolve this? Or is there a better way to set up this form?

     

    The areas with the form separator are hidden using conditional logic. You have to select defects found to yes in order to see the first form separator. Then every time you check "more defects?" it adds another line with another form separator. Not all of the separators are showing up.

    Page URL:
    https://form.jotform.com/53513952560960

    all form separator displaying a
  • Profile Image
    JotForm Support

    Answered by Mike_G on December 23, 2015 at 06:44 PM

    I was able to see what you mean and I was able to know why it resulted to that. I can see that only 6 of the Form Separator widget are showing on the form. If I'm not mistaken, (please feel free to correct me, if I'm wrong) you added the other fields(including the widget) by duplicating it using the Manage Multiple Fields option, is that correct?

    By doing that you would be able to duplicate the fields including the widgets(as a field), yes, but not the widgets function, that is why it is not showing.

    I'm sorry for the inconvenience, I understand that it would be a tedious work for you to add everything back one by one after deleting that widgets that's already in there and re-create all the conditions, but that's the only way to resolve this. You need to add every widget one by one to the form to resolve this.

    Let us know if you need any further assistance. Thank you.

    Thank you.

  • Profile Image

    Answered by AirtexDesignGroup on December 28, 2015 at 08:37 AM

    Well that is disappointing. It seems like this widget is poorly designed if it cannot be handled like other widgets. Why release something if it needs to be treated differently from other widgets? I did duplicate it using  the Manage Multiple Fields option. I also duplicated the Image Upload Preview widget and that works just fine.

    This was my workaround to the fact that none of the Multiple Entries widgets were able to include a file upload in a dynamic list. Now I need to go back and redo a bunch of work just because I am now finding out that something as simple as a line separating two fields can't be duplicated using a feature designed to allow the user to easily duplicate fields. I didn't think to test the form after the first two entries showed up correctly. I guess I put too much faith into Jotform's abilities to work as you would expect it to.

    So I guess my question is why am I paying for a service when you are releasing broken features? This is an issue that I would have thought would be caught by a QA team when testing new widgets and features for the site. And even if you couldn't fix it, a simple disclaimer on the widget description for the end user would be helpful. I was initially impressed by Jotform but now I am pursuing other options. I would expect to not feel like a beta tester when paying for a service.

  • Profile Image
    JotForm Support

    Answered by Chriistian on December 28, 2015 at 10:15 AM

    Hi,

     

    Sorry for the inconvenience. I was able to replicate this issue in my test form (https://form.jotform.com/53614438258965). I have added two separator widget in the form. Added the second form separator by duplicating the first one (Manage Multiple Fields > Duplicate).

    But when I preview the form, only one form separator widget is displayed.

    Let me forward this to our development team for them to fix the issue. For now, you can try another workaround. Please try to update the widget setup instead of deleting and re-adding the widget. 

    1. Open widget wizard.

    2. Without changing anything, click Update Widget so the widget settings is refreshed.

     

     

    We will inform you on this thread any updates to the issue.
    Regards.

  • Profile Image
    JotForm Support

    Answered by TitusN on January 20, 2016 at 11:35 PM

    Hello,

    The Form Separators have been fixed. 

    It was a bug on one of our core widget servers (not previously caught) - please accept our apology. 

    Kindly refresh the form separators on your form to get the update we've published (we can do it for you, if you'd like)

    Let us know if you experience any difficulty.