What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Visual Report Builder: Unable to make changes or edits on existing report

    Asked by markashton on January 11, 2016 at 05:35 AM

    I have a form ....

    It has visual reports ...

    Can I edit them? No

    Why? Click the dropdown on reports. Click the pencil next to the report ... comes up with a completely new visual report as if you want to create a new one ... not the original which you want to edit.

    My only task to day for my client ... can't do it. 

    Don't ask me to do anything ... you do it ... here's the instruction from me ...

    Create a visual report ... save it ...  close it ... try and edit it ... by going to the form ... selecting reports ... little pencil next to report.

    Regards mark

  • Profile Image
    JotForm Support

    Answered by Charlie on January 11, 2016 at 10:59 AM

    Apologies for the inconvenience. I was able to replicate the problem and was able to find more.

    Problems:

    - Unable to edit the existing visual report

    - Editing a visual report will open the visual report but will create a new one once saved.

     

    I have forwarded this to our developers to have it fixed. Again, I'm sorry for the inconvenience.

  • Profile Image
    JotForm Support

    Answered by Charlie on January 11, 2016 at 01:01 PM

    I understand Mark, I would like to give you a time frame on this, but this is assigned to our developers. As of the moment, it has just been escalated and the priority of it has not yet been assigned. But rest assure that bugs are being treated with utmost importance.

    I have tested again the Visual Report builder as I have reported a similar thread last week. It seems like the problem has already been resolved. I also see that there was a fix implemented for the last hour regarding reports that may have, at the same time, fixed this specific problem. I'll leave the thread opened and escalated to have it better check. But please do try if the problem persists in your end.

    Apologies for the inconvenience.