What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    How to create an Auto Responder ?

    Asked by jackkellerinc on January 18, 2016 at 06:49 PM
    How do I get the autoresponder to send the link with the session variable for the second page as shown on your support page in reference to keeping a customer from loosing all of the work if they navigate away from the 2nd page on accident? (http://www.jotform.com/help/97-How-to-Save-Forms-to-Continue-Later )
    auto responder
  • Profile Image
    JotForm Support

    Answered by Kevin_G on January 18, 2016 at 06:51 PM

    Please, follow this guide in order to create your Auto Responder : http://www.jotform.com/help/26-Creating-a-Form-Autoresponder 

    Do let us know if you need more help, we will be more than happy to assist you.

    Regards.

  • Profile Image

    Answered by jackkellerinc on January 19, 2016 at 09:31 AM

    I already did all that prior but it doesn't work

     

  • Profile Image
    JotForm Support

    Answered by Welvin on January 19, 2016 at 12:07 PM

    Please let us know the form URL here so we can check it for you. It's either your settings are incorrect or email is filtered as spam. We need to test it. 

  • Profile Image

    Answered by jackkellerinc on January 19, 2016 at 12:45 PM
    https://form.jotform.com/41306296441148?email8={email8} &ownerName[first]={ownerName:first}&ownerName[last]={ownerName:last}


    ...
  • Profile Image
    JotForm Support

    Answered by Welvin on January 19, 2016 at 02:46 PM

    You do not have an autoresponder in the form. I think you have deleted that one. I have created it again and tested the form and I was able to receive the email:

    Please check and test it again. 

  • Profile Image

    Answered by jackkellerinc on January 19, 2016 at 03:45 PM
    You were using the wrong form. It should be https://form.jotform.com/60116964293963

    ...
  • Profile Image
    JotForm Support

    Answered by Kevin_G on January 19, 2016 at 05:50 PM

    Hi,

    I just tested your form : https://form.jotform.com/60116964293963

    And I received the email with the link to your second form :

    Could you please try again ? 

    Are you still having the issue ? 

    We will wait your response.

    Thanks.

  • Profile Image

    Answered by jackkellerinc on January 20, 2016 at 09:45 AM
    Yes I get the link, that’s not the issue… When I click the link the form is blank. It should be filled in with the session info

    ...
  • Profile Image
    JotForm Support

    Answered by Welvin on January 20, 2016 at 11:06 AM
  • Profile Image
    JotForm Support
  • Profile Image

    Answered by jackkellerinc on January 20, 2016 at 04:45 PM
    I must still be missing something. When I submit the form and then fill out the next page click next on the page break and then close the page, check the email from the autoresponder and the click the link none of the info reappears

    ...
  • Profile Image
    JotForm Support

    Answered by Kevin_G on January 20, 2016 at 06:08 PM

    I followed the steps you provided us, and I was unable to replicate your issue, I have filled some fields on the form and then closed it, when I click on the link I received the fields are filled with the previous entered data : 

    I tested submitting your first form : https://form.jotform.com/60116964293963 

  • Profile Image

    Answered by jackkellerinc on January 21, 2016 at 10:45 AM
    Where is the session info stored? On the users browser?

    ...
  • Profile Image
    JotForm Support

    Answered by Welvin on January 21, 2016 at 11:57 AM

    You are using the session URL method. The data is saved to our servers. When you are using Autofill, data is stored to the user's browser.

  • Profile Image

    Answered by jackkellerinc on January 21, 2016 at 03:45 PM
    I just tried it again and everything is blank when I click the link in the autoresponder except for the 3 questions from form 1

    ...
  • Profile Image
    JotForm Support

    Answered by Kevin_G on January 21, 2016 at 05:10 PM

    This is quite odd, since we are not able to replicate your issue, I tested with your form and my colleague's form and it worked as you need.

    Which web Browser are you using ? 

    I tested it on Google Chrome.

    Could you please try with other Browser ? 

    We will wait for your response.

    Thanks.

  • Profile Image

    Answered by jackkellerinc on January 22, 2016 at 09:45 AM
    The form we were referring to was my test form. I started my production form which is where I’m having issues. My apologizes. Start at https://form.jotform.com/60195153690961 & then it goes to https://form.jotform.com/50494772631964

    ...
  • Profile Image
    JotForm Support

    Answered by Boris on January 22, 2016 at 11:49 AM

    The link in the autoresponder seems to be working fine.

    However, I've noticed that the link in the autoresponder is different than the link in the Thank You page redirect. This means that your users are receiving one session link, but are actually redirected to start entering their data with a different link.

    First form is using autoresponder link:

    https://form.jotform.com/50494772631964?ownerName[first]={ownerName:first}&ownerName[middle]={ownerName:middle}&ownerName[last]={ownerName:last}&ownerName[suffix]={ownerName:suffix}&phoneNumber6={phoneNumber3}&email8={email}

    First form is redirecting to the following Thank You page:

    https://form.jotform.com/50494772631964?session={email}&ownerName[first]={ownerName:first}&ownerName[middle]={ownerName:middle}&ownerName[last]={ownerName:last}&ownerName[suffix]={ownerName:suffix}&phoneNumber6={phoneNumber3}&email8={email}

    In order to make sure your users are filling out a session from the very start, please change the URL of your Thank You page to be the same as the one in the Autoresponder.

    Please let us know if this fixes the issue you were having, and if you are able to continue your session after making this change. Thank you.