Our form is not showing up each time when we try to open it

  • Profile Image
    pauljones9005
    Asked on February 02, 2016 at 07:37 AM

    JotForm seems extremely unreliable lately and the fact that I cannot speak to a person about it is a big problem. I have an embedded JotForm showing up only sometimes when it is pulled up: sometimes it appears and is working correctly, other times it is missing entirely. On other forms, the email addresses that are attached to the JotForm are not all receiving messages that I send. For example, if 3 email addresses are attached, only two of the recipients receive the message. The worst part about that is that all of the recipients were previously receiving their messages, and for some inexplicable reason, they suddenly stop going through. I would appreciate an immediate response. Thank you!

  • Profile Image
    Ben
    Answered on February 02, 2016 at 11:42 AM

    Based on what you have mentioned it seems that there are several issues present for you.

    1. With the form not working properly each time

    2. with the emails not being delivered to the specified email addresses

    For the issue with the emails we will reply to you on your other thread here: http://www.jotform.com/answers/762336

    In regards to the form, can you please tell us if the form is embedded somewhere on your website and if so, what is the link to the same? That would allow us to check it out and see what could be causing the same for you.

    If this happens on the form when you access it over direct URL, do let us know the link that you use to check it out as well.