Wordpress oEmbed Plugin: Unable to submit form when using this plugin

  • Profile Image
    ffacamp
    Asked on February 02, 2016 at 09:52 AM

    I published the form following the instructions on the page, the form works fine, but when I press submit (I was testing the form) it says please wait and never finishes loading.

  • Profile Image
    Charlie
    Answered on February 02, 2016 at 12:45 PM

    I presume you are referring to the JotForm oEmbed plugin found here: https://wordpress.org/plugins/jotform-oembed/installation/?

    I made a test setup and was able to replicate the problem using that plugin.

    Could you please try the methods found in this guide: http://www.jotform.com/help/324-A-Guide-To-Forms-For-WordPress-JotForm-Users.

    You could also try using the iFrame embed code instead: http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code 

     

    I have forwarded this to our developers to have the JotForm oEmbed plugin to be checked and fixed. Apologies for the inconvenience.

  • Profile Image
    ffacamp
    Answered on February 05, 2016 at 11:27 AM

    I used the embed method for wordpress.com as it is a hosted site. I tried to re-do it and the same outcome happened. How can I fix this?

    I also tried the iframe and that didn't even load properly on the page. 

    My whole form is showing, its just the submit button that won't work.

  • Profile Image
    Charlie
    Answered on February 05, 2016 at 12:21 PM

    May I know what iFrame are you using? We have our own iFrame embed code mentioned in this guide: http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code 

    Please do get the iFrame embed code that we have under the "Publish" wizard. You can paste it in your Wordpress page/post that accepts HTML and script codes. I checked your website and it is still showing me that it is using oEmbed.jotform.com.

    In your "Publish" wizard, copy the code after you select the "iFrame" option.

     

    Please embed the iFrame and let us know, we will check the website if there's any additional errors that we can find as to why the iFrame does not work for you. We'll wait for your response.

  • Profile Image
    ffacamp
    Answered on February 09, 2016 at 01:07 PM

    thats the iframe I used, I just followed the directions completely and it doesn't load. I can't leave the iframe version up because it is just the code. 

  • Profile Image
    Ben
    Answered on February 09, 2016 at 03:22 PM

    Could you please set up the private page for us with the iframe embed code - the one that you get from under Publish wizard.

    Since that one is not using iframe sandboxing, it should allow the iframe to work out of the box, and setting it up within a hidden page - or password protected page would allow us to see the issue, while others would not see the same page.

  • Profile Image
    ffacamp
    Answered on February 11, 2016 at 02:44 PM

    http://ohioffa.org/camp/contact/

    I got the iframe code from under the publish option and copied the code. Im really not sure what else to do because using the wordpress platform is the only option that works, but then the submit button won't work. 

  • Profile Image
    Scott
    Answered on January 09, 2017 at 10:41 AM

    Hey ffacamp,

    Our developers issued a fix for this bug.

    Forms that are embedded through Wordpress oEmbed Plugin should be submitting without any problems now.

    If you are still experiencing problems on submit, please embed your form again using the plugin.

    If you have any other questions about this process, we will be waiting to hear from you,

    Cheers.