Submit button gets stuck at Please wait... when using the oEmbed Plugin for WordPress

  • Profile Image
    miszisz
    Asked on February 02, 2016 at 11:22 AM

    Embedded the code into a WP sites and when I clicked on Submit button it just said "Please Wait". Tried number of time but no success.
    What can I do?

     

    Thanks,

     

    Monika

  • Profile Image
    Welvin
    Answered on February 02, 2016 at 01:16 PM

    There's seems to be an error in the oEmbed Plugin that you are currently using. I will have to test this and let you know if I can replicate it.

    For now, please use our Embed Form Plugin: https://wordpress.org/plugins/embed-form/. You can also just embed it using one of our embedding methods. You can have the iframe: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

  • Profile Image
    Welvin
    Answered on February 02, 2016 at 01:28 PM

    I can replicate this. You can see the problem in my screenshot. You have to access this page to view it.

    I have now forwarded this thread to our developers. If there are updates, you should know it through this thread.

  • Profile Image
    drrichar
    Answered on February 29, 2016 at 10:51 AM

    No answer to this problem yet?

  • Profile Image
    Welvin
    Answered on February 29, 2016 at 11:55 AM

    I'm sorry, but yes, we don't have an update yet. If there's any, our developers will let you know here. 

  • Profile Image
    Scott
    Answered on January 09, 2017 at 10:42 AM

    Hey drrichar,

    Our developers issued a fix for this bug.

    Forms that are embedded through Wordpress oEmbed Plugin should be submitting without any problems now.

    If you are still experiencing problems on submit, please embed your form again using the plugin.

    If you have any other questions about this process, we will be waiting to hear from you,

    Cheers.