Page Breaks do not work on iPad

  • Profile Image
    monahandesign
    Asked on February 17, 2012 at 09:35 AM

    the site is onelupine.com/wholesale.php

    you can enter the password but when you press the next button to go to the next page, it doesnt load...

  • Profile Image
    aytekin
    Answered on February 17, 2012 at 01:28 PM

    This is not a supported feature of JotForm. I believe it is a hack in the forums. So, we can't really help you with it. Sorry. 

  • Profile Image
    monahandesign
    Answered on February 17, 2012 at 04:12 PM

    It is listed as something you can do in your user guide which is where I found it? 

    http://www.jotform.net/help/57-Conditional-Logic-on-Forms

    other than the password problem the forms should work on the ipad ios right?

  • Profile Image
    NeilVicente
    Answered on February 17, 2012 at 06:05 PM

    @monahandesign

    Yes, forms created with JotForm should work fine with iPads. However, scripting must be enabled in the iPad browser for the conditions (and other functions that rely on JavaScript) to work.

  • Profile Image
    monahandesign
    Answered on February 18, 2012 at 12:26 AM

    Scripting is enabled. I have tested it on a windows 7 phone, a mac, a windows box running vista, and they all have worked. the main proble now revolves around the iphone and ipad, which the form doesnt work properly on. I trouble shot the login password by setting up my own password page and pointing to the form embeded in a php document. The bigger problem now is that I have eliminated the login but now the next buttons dont work for the ipad or iphone. Like I said the scripting option on the iphone is enabled. so im not sure where the problem is lyng now.

    current page witht the embed form

    http://onelupine.com/wholesale2.php

    u1

    p1

  • Profile Image
    NeilVicente
    Answered on February 18, 2012 at 08:14 AM

    Would you mind sharing the password so I can see the exact page where the form is embedded? Something might be messing with your form's scripts. Please let me check them. Thanks!

  • Profile Image
    monahandesign
    Answered on February 18, 2012 at 08:31 AM

    u1

    p1

  • Profile Image
    NeilVicente
    Answered on February 18, 2012 at 09:49 AM

    I don't have an iOS device available right now so I tested your form using an Android phone but I was unable to recreate the problem.

    My hunch tells me that it is probably the large size of your images that is causing the scripts to not load. Do you have a fast internet connection on your iPad?

    Can you please try this simple form on your iPad and check if the page breaks work nicely?

  • Profile Image
    monahandesign
    Answered on February 18, 2012 at 09:53 AM

    Im pretty sure I figured it out. The embed code was messing up somewhere on the ios device because I changed out the embed to an iframe embed. Now it works on an iphone. so Im guessing it will work on the ipad. I am waiting to here back from my client that is using the ipad. thank you for your help fingers crossed that it works. lol