The "required" option doesn't work well !