What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    SSL form fields not showing in IE 8

    Asked by ijsmale on April 21, 2010 at 01:21 PM


    I'm having a problem with my forms using Internet Explorer 8 - this has just happened within the since the JOTFORM update - I have had customers call me saying they cannot submit my forms.    I have my forms on an SSL certified  page ( https ) within my web site.   This allows customers to submit credit card information to pay accounts etc.  which I collect from Jotform database on the HTTPS connection and then process in my terminal.   So the problem happens when I try to open the the page with the forms,  IE 8 gives the message  Do You want to view only the web page content that was delivered securely?  This web page contains content that will not be delivered using a secure HTTPS connection which could compromise the security of the entire web page".    So when I click on the " YES " button the page opens and none of the submission fields are displayed so there is no form to fill out,  but the  gold padlock icon is displayed showing the page is secured with my security certificate.   If I click on the  "NO" button the page opens with all the form fields but there is no gold padlock / security icon or certificate information.      This was not happening previous to the  JOTFORM  interface update.    So somehow the fields are not secure now but were prior to the update.  

     

    What can be done to correct this problem ? 

    Ian

  • Profile Image

    Answered by ijsmale on April 21, 2010 at 02:04 PM

    I found the problem - I had to update all my scripts in my web page,  and make sure the HTTPS was in the script.