Authorize.net: Subscriptions no longer work - error on transaction during submission

  • Profile Image
    shift6
    Asked on March 04, 2016 at 04:09 PM

    Im receiving an error upon submitting all my payment forms that are using Authorize.net integration. These forms have been working until recently. I have seen many other users experiencing the same issue with Jot Form but have yet to see a resolution.

    The error reads "error on transaction" click "go back" and fix.

    There are no additional error codes along with this. Please advise as no one can currently submit payments.  

  • Profile Image
    david
    Answered on March 04, 2016 at 06:10 PM

    There should be a link to go back and fix the error.  If there is not, it may be an error with your API login ID or transaction key.  Check both to make sure they are correct:

  • Profile Image
    shift6
    Answered on March 04, 2016 at 06:53 PM

    The link goes no where, just to a blank page. 

    API credentials have been checked an re-checked. Ive even created new trans keys. When I test integration I get a successful result. 

    We've been using these forms for many months with no problems until just recently. Something has changed on most likely JotForms end as Ive been on the phone with Auth.net and everything is setup correctly over there.

  • Profile Image
    shift6
    Answered on March 04, 2016 at 07:18 PM

    And to be sure this is clear. The error happens after submitting the form.

  • Profile Image
    EltonCris
    Answered on March 04, 2016 at 10:46 PM

    Thanks for providing these details and apologies for the inconveniences caused. I have now raised this to our developers after reproducing the problem in your form.

    You will be informed here once this is fixed.

    Thanks!

  • Profile Image
    shift6
    Answered on March 04, 2016 at 10:53 PM

    Ok thank you

  • Profile Image
    shift6
    Answered on March 05, 2016 at 11:03 AM

    Will this issue be resolved soon? If not I will need to find an alternative ASAP as our forms are payment forms and thus people are unable to submit their payments. 

  • Profile Image
    EltonCris
    Answered on March 05, 2016 at 01:45 PM

    There is still no update about this. Since it is weekend, I'm afraid our developer will not be able to look at this today. Rest assured that someone will get back to you with this as soon as this is fixed. I couldn't promise you a time frame but I'm pretty sure this won't take long since this is core feature issue.

    Thanks!

  • Profile Image
    shift6
    Answered on March 05, 2016 at 01:49 PM

    Thats unfortunate as we cannot have any more missed payments from our subscribers. We do higher percentage of payments VIA phone but for the people who choose to user the web we must have a payment for readily available as this will directly hurt us when they cannot place payment. 

    So we will have to move over to a competitor form site to get payment forms back up. 

  • Profile Image
    EltonCris
    Answered on March 05, 2016 at 09:18 PM

    We completely understand and we sincerely apologize for that.

    While this isn't yet fixed, you may want to consider using different payment gateways like Paypal or Stripe. These has subscriptions as well which is working just fine.

  • Profile Image
    NeilVicente
    Answered on March 07, 2016 at 03:33 AM

    @shift6

    This should be fixed by now. Sorry for the inconvenience.

    Regards

  • Profile Image
    shift6
    Answered on March 07, 2016 at 01:02 PM

    Thanks guys. I did use a competitor form for the weekend, but I will be remaining here with jot form as i was not impressed with the competitors auth.net subscription options. 

     

    Thanks

  • Profile Image
    david
    Answered on March 07, 2016 at 02:10 PM

    You are very welcome, our apologies again for the bug.  If there is ever anything else we can assist you with, let us know and we will be happy to help.

  • Profile Image
    krswes
    Answered on November 05, 2016 at 02:47 PM

    HELP! We are experiencing the same issue with this form: https://form.jotform.com/61084907053151