Forms not saving, error page when accessing form, perhaps caused by Footer fields

  • Profile Image
    samspencer
    Asked on February 23, 2012 at 07:28 PM

    I noticed that Footer fields are no longer an option under Form Tools, so I'm guessing they were removed recently. Unfortunately I had some footer fields in my forms and I think they were responsible for some problems, until I deleted those fields. I wanted to bring this up in the hopes that you guys can fix this problem so it doesn't affect other users.

    I just had a problem where my forms would not save. I clicked the Save button and the animation just looped without actually saving. Also, when I tried to access the form at www.jotform.net/form/[formNumber], the following text came up on a white screen:

     ../../js/builder/build_source.js:1158: TypeError: Cannot read property 'type' of undefined var input = this.createInputHTML(prop.type.value, id, prop, false, ^

    I noticed that my Footer fields all read "Question is not defined, should be defiend at createInputHTML() function" so I deleted the footers, and suddenly I could save without problem. I could also access the forms at /form/ as usual.

    I hope there is some way to prevent this happening to other users. Maybe automatically convert all footer fields into Free Text (HTML) fields?

  • Profile Image
    Mike_T
    Answered on February 23, 2012 at 07:54 PM

    Please accept our sincere apologies.

    This problem has been forwarded to our Development Team.

    We will get back to you as soon as possible.

  • Profile Image
    samspencer
    Answered on February 23, 2012 at 09:54 PM

    Hi Mike,

    Thanks for getting back to me. It's no longer urgent but if it could affect others then it's worth looking into.

    Thanks,

    Sam

  • Profile Image
    jonram91
    Answered on February 24, 2012 at 01:31 AM

    I'm experiencing the exact same problem with the footer fields. What should I do?

  • Profile Image
    mliz
    Answered on February 24, 2012 at 01:36 AM

    Our developers have already been informed on this issue, once we have the fix we will let you know.

    Sorry for the inconvenience.

  • Profile Image
    samspencer
    Answered on February 24, 2012 at 03:31 AM

    Jonram91,

    Have you tried deleting the footer fields? That's all I had to do. Open up your form on the editor, delete the footer fields (without touching anything else first that would make it try to save), then save after the footers are deleted. Began working for me immediately after that.

    Good luck,

    Sam

  • Profile Image
    seyhuns
    Answered on February 24, 2012 at 07:20 AM

    This has been fixed. Thank you for reporting!