What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form was submitted with required field not filled out

    Asked by Impacct on March 10, 2016 at 10:47 AM

    Please see attached

    This form has been working properly for quite some time, but yesterday a user was able to submit the form despite the required document upload not being done.

     

    Please advise as to how this happened and about what is being done to prevent it from happening again

    We need to requirements on fields to be effective 100% of the time. 

     

    Thanks,

     

    -Ilana

    Page URL:
    https://form.jotform.com/51725625657967

    Screenshot
    settings able to submit attached document
  • Profile Image

    Answered by Ben on March 10, 2016 at 11:56 AM

    I see that this is the second thread in regards to the same issue. As such and since my colleague is already working on the first thread, please do reply back on that one instead of here.

    This is the link to the previous thread: http://www.jotform.com/answers/791839

    Thank you.

  • Profile Image

    Answered by Impacct on March 10, 2016 at 03:00 PM

    Can we use this thread instead? when I click that link I am redirected to my forms page. 

    In response to the response on the other thread:

    I understand the issue is something you can't recreate. Nonetheless, it still happened and is now happening with other forms as well. I need my forms to work as they should and for the required settings not to occasionally fail out of the blue. Please get this fixed

    https://www.jotform.com/edit/333183928032628830

     

  • Profile Image
    JotForm Support

    Answered by BJoanna on March 10, 2016 at 04:21 PM

    Yes, we can use this thread. 

    I have also tested your form, but I was not able to submit it without filling all required fields. 

    Can you please provide us more details about your issue? Did you embedded your form to website? If so please provide us URL of your website so that we can test your form there. Maybe there is some issue with your embed code. 

    You mentioned that this has happened on your other forms as well. Did this happened to same user of different users? Do you maybe know which browser and device they used? I would suggest you to use Google Chrome or Mozilla Firefox.

    Also I see that latest link you provided is edit link of your submission. Is this issue related to editing of submissions? Are uploaded files missing when submission is edited or when when your users submit your form using direct link of the form?

    Looking forward to your reply. 

  • Profile Image

    Answered by Impacct on March 10, 2016 at 05:02 PM

    The form is not embedded. people use the jotform link to access the form

    We are aware of this issue not because of the user filling out the form, but because of the approver who receives the form.

    The user is being allowed to submit without completing the required fields, but the approver gets an error message the information from these fields is missing when they try to submit the form

    I thought at first maybe the attachment had dropped off the first form (CIF) but I checked the dropbox copy (we have a copy saved to dropbox on submission) and I didn't see the attachment there either

    Now we are having a requirements issue on this other form (VIF), but it is for a radial button selection, not for an attachment. It seems like there is something specific to the required setting that isn't working every time 

    This is happening when various people fill out the form, but is not something caught by the user filling it out. 

  • Profile Image
    JotForm Support

    Answered by jonathan on March 10, 2016 at 06:14 PM

    The user is being allowed to submit without completing the required fields, but the approver gets an error message the information from these fields is missing when they try to submit the form

    Can you please describe more how the "approver" submit the form?  Were they using a different link of the form? Share to us the link or URL that the "approver" were using to submit the form.

    I am sorry as I am bit confused by the details. From what I understand, it seems you were referring to 2 different way the "user" and the "approver" were submitting the form. 

    I can only assume that the approver must be using an Edit Link of the form. But we need to confirm first so we can properly check the exact problem.

    Thanks.

     

     

     

     

  • Profile Image
    JotForm Support

    Answered by jonathan on March 10, 2016 at 06:15 PM

    Now I truly apologize for the blunder. I missed the URL link https://www.jotform.com/edit/333183928032628830 which you had already provided.

    Let me check now. I'll get back to you shortly.

     

  • Profile Image
    JotForm Support

    Answered by jonathan on March 10, 2016 at 06:41 PM

    In the Edit Link https://www.jotform.com/edit/333183928032628830 there is an empty *Required field

     

    So there is a required validation error when submitting the form due to that empty required field.

    I checked that submission ID 333183928032628830 on your form, and I see the "Please selext tax ID" field is empty as well.

     

    this means that the original submission already have issue since that field was suppose to be a *Required field.

    So far only this specific submission have that empty data for the field.

    I am not sure what could have happened to this specific submission, but the end user was able to submit the form without filling the required field. Usually, this glitch can happen if there is issue with the browser being used (assuming the form URL was being used). 

    The common cause of script validation failing on the form was due to javascript being disabled on the browser. The form requires javascript to be available/enable to make most if its funcctionality work.

    Can you please also check if this is only one submission that have this issue? Can you share to us if there were more?

    Thanks.

     

     

  • Profile Image

    Answered by Impacct on March 11, 2016 at 11:11 AM

    Thank you, this is helpful

    We are working to confirm these submitters have JavaScript enabled.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on March 11, 2016 at 12:17 PM

    Hello Impacct,

    On behalf of my colleague, you are welcome.

    I also wanted to ask if you have embedded your form in any webpage. If you have, please share the webpage URL and we will take a look.

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by Impacct on March 11, 2016 at 01:03 PM

    Hello,

     

    No, I have already said it is not embedded in any webpage: people use the jotform link

     

    Unfortunately it looks like we need to look into this further: the responses I have gotten so far indicate people are using Chrome or Firefox and have JavaScript enabled 

  • Profile Image
    JotForm Support

    Answered by ashwin_d on March 11, 2016 at 01:12 PM

    Hello Impacct,

    This is strange. If you are using form's direct URL, I do not see any reason why the required fields will not be captured.

    I would suggest you to add "NoScript" widget in your form. This will ensure that if JavaScript is not enabled in browser, submission will not be allowed in form. Once you add this widget in form, I would suggest you to monitor your submissions and get back to us if you see any missing required field again.

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by Impacct on March 12, 2016 at 03:07 PM

    Thank you, I have added NoScript to all forms. Hopefully this will resolve the issue.

    Thanks again,

     

    -Ilana

  • Profile Image
    JotForm Support

    Answered by jonathan on March 12, 2016 at 03:37 PM

    You are quite welcome. :-) 

    Do let us know at once if issue persist.

    Regards,